Subject: Looking for pgbench Benchmark Results Across PostgreSQL Versions

From: Özkan Pakdil <[email-masked]>
Date: Thu, 8 May 2025 21:07:36 +0100

Hi everyone,

I’ve been searching for a website that provides pgbench results for
different PostgreSQL versions, from 11 to 18, including the latest beta or
alpha releases.

Does anyone know of such a site?

Thanks!

---

From: SERHAD ERDEM <[email-masked]>
Date: Fri, 9 May 2025 08:03:37 +0000

Hi ,you may look at this ,
https://smalldatum.blogspot.com/2023/10/postgres-versions-11-12-13-14-15-and-16.html
[https://blogger.googleusercontent.com/img/b/R29vZ2xl/AVvXsEiTQGvK-hx60qAae2LBQxBCnM0DOvzplpt8dtv0q29mtGvASKuop-QcubW1fmGgdfwer6SEBRoAPK1lN9ejTt9ofTcN2YVQA7FyH2gplVhDiiLULFvYZxykzk8NYjYqskdhEXjmqZDOvLObgNIlRjKzpzgBIl2S3Lz-V4dnQTpm8YWOUOz0daagV3eOJApz/w1200-h630-p-k-no-nu/QPS%20relative%20to%2011.21_%20point%20queries,%20part%201.png]<https://smalldatum.blogspot.com/2023/10/postgres-versions-11-12-13-14-15-and-16.html>
Postgres versions 11, 12, 13, 14, 15, and 16 vs sysbench with a medium server - Blogger<https://smalldatum.blogspot.com/2023/10/postgres-versions-11-12-13-14-15-and-16.html>
I used sysbench and my usage is explained here.Postgres was configured to cache all tables. This benchmark used a c2-standard-30 server from GCP with 15 cores, hyperthreads disabled, 120G of RAM, Ubuntu 22.04 and 1.5TB of NVMe SSD with XFS (SW RAID 0 over 4 local devices).
smalldatum.blogspot.com

________________________________
From: Özkan Pakdil <[email-masked]>
Sent: Thursday, May 8, 2025 8:07 PM
To: [email-masked] <[email-masked]>
Subject: Looking for pgbench Benchmark Results Across PostgreSQL Versions

Hi everyone,

I’ve been searching for a website that provides pgbench results for different PostgreSQL versions, from 11 to 18, including the latest beta or alpha releases.

Thanks!