Subject: Re: psql help

From: "David G. Johnston" <[email-masked]>
Date: Thu, 4 Jul 2024 18:16:32 -0700

On Thu, Jul 4, 2024 at 4:56 PM Murthy Nunna <[email-masked]> wrote:

>
>
> How can I rewrite the above in psql
>

The only real trick is using a psql variable instead of the shell-injection
of the environment variable.  Use the --set CLI argument to assign the
environment variable to a psql variable then refer to it in the query using
:'timout_mins'

Removing the limit 1 should be as simple as not typing limit 1 when you
bring the query into the psql script.

David J.

---

From: Murthy Nunna <[email-masked]>
Date: Fri, 5 Jul 2024 03:54:56 +0000

Sorry, there is no problem with the following statement and the environment variable. It works fine. But it terminates only one PID due to LIMIT 1. I want to terminate all pids that meet this criteria. If I remove LIMIT 1, pg_terminate_backend(pid) will not work as it expects only one pid at a time. So, the question is how to rewrite this psql so it loops through all pids one pid at a time? Thanks in advance for your help.

SELECT pid, pg_terminate_backend(pid) FROM pg_stat_activity
    WHERE pid IN (select unnest(pg_blocking_pids(pid)) from pg_stat_activity where cardinality(pg_blocking_pids(pid)) > 0)
                 and usename = 'DBUSER_10'
                 and now() - state_change >= interval $a'${TIMEOUT_MINS}'$a
                 order by now() - state_change >= interval $a'${TIMEOUT_MINS}'$a desc limit 1;

From: David G. Johnston <[email-masked]>
Sent: Thursday, July 4, 2024 8:17 PM
To: Murthy Nunna <[email-masked]>
Cc: [email-masked]
Subject: Re: psql help

[EXTERNAL] – This message is from an external sender
On Thu, Jul 4, 2024 at 4:56 PM Murthy Nunna <[email-masked]<mailto:[email-masked]>> wrote:

The only real trick is using a psql variable instead of the shell-injection of the environment variable.  Use the --set CLI argument to assign the environment variable to a psql variable then refer to it in the query using :'timout_mins'

Removing the limit 1 should be as simple as not typing limit 1 when you bring the query into the psql script.

David J.

---

From: hubert depesz lubaczewski <[email-masked]>
Date: Fri, 5 Jul 2024 13:05:24 +0200

>                  order by now() - state_change >= interval $a'${TIMEOUT_MINS}'$a desc limit 1;

Did you try?

I don't see any reason why it wouldn't work with just 'limit 1' removed.

Best regards,

depesz