Subject: Re: Customize psql prompt to show current_role

From: Dominique Devienne <[email-masked]>
Date: Mon, 23 Sep 2024 17:37:58 +0200

On Mon, Sep 23, 2024 at 5:16 PM Adrian Klaver <[email-masked]> wrote:
> On 9/23/24 08:07, Dominique Devienne wrote:
> > I often resort to \conninfo, but it's less automatic and
> > harder to visually parse (IMHO) compared to a custom ad-hoc prompt.

> For me that shows the user that connected(session_user) not the current_user.

yeah, sure, I realized that just after sending my last post...
I resort to using both \conninfo *and* `select current_role`.
I used \conninfo to tell me which server I'm on (since not
on the default prompt, before I played with it today), which
session_user I'm connected with (ddevienne or dd_login
in my recent example), and finally `select current_role`
which matters in my use-cases (session_user or dd_admin or dd_user).

I'd like not to have to type those commands/queries all the time,
and have them in the prompt at all time. I get that it's not for everyone,
nor even necessary all the time, but I sincerely think it is definitely useful.

I'd be glad to use Pavel's proposed %N. --DD

---

From: Raphael Salguero Aragón <[email-masked]>
Date: Wed, 27 Nov 2024 15:14:04 +0100

Am 23.09.2024 um 17:37 schrieb Dominique Devienne <[email-masked]>:
> I'd be glad to use Pavel's proposed %N. —DD
> 

Hi all,

I just wanted to add that we are also supporting a larger customer with exactly the same request.
Perhaps this increases the value of the adjustment a little more :)

Best regards!
 Raphael Salguero

---

From: Dominique Devienne <[email-masked]>
Date: Wed, 27 Nov 2024 15:45:05 +0100

> Perhaps this increases the value of the adjustment a little more :)

Hi. Thanks for sharing Raphael. That's a 3rd notch Tom! :)
So is it the proverbial "third time's a charm" and the community would
revise its initial rejection?
I keep making that point, but the fact this is entirely opt-in,
mitigates the "expensive" argument IMHO.
FWIW. Thank you for considering this RFC again, especially since
there's a patch for it. Respectfully, --DD