Subject: Data Versioning

From: "Sunit Bhatia" <[email-masked]>
Date: Thu, 02 Aug 2001 01:21:40

Does any body know if pgsql supports any kind of versioning of  binary 
objects or data. e.g. If I'm storing a binary file in a row of a table, I 
would want to see different versions of the same biary file. Everytime I do 
a write, the version number should be bumped up !!

Is it possible to do it in pgsql or any other databases.
I'm using JDBC for connecting to database.

thanks

_________________________________________________________________
Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp

---

From: "Yasuo Ohgaki" <[email-masked]>
Date: Thu, 2 Aug 2001 11:13:01 +0900

> a write, the version number should be bumped up !!

With PostgreSQL, you can create RULE to keep old values.
(Much easier than other DB, thanks to RULE)
Refer to PostgreSQL manual for details.

Yasuo Ohgaki

---

From: Barry Lind <[email-masked]>
Date: Wed, 01 Aug 2001 19:46:49 -0700

You should be able to easily design a database schema that does what you 
want.  For example two tables,

files
------
file_id (PK)
file_name text
...

file_versions
-------------
file_version_id (PK)
file_id (FK to files.file_id)
version integer not null
data oid not null
...

Then when your application creates a new file you would insert a row 
into both the files and file_versions table.  When your application 
'updates' a file it just inserts into the file_versions table the new 
version.

There is no explicit support for what you are trying to do native, and I 
don't know of any other databases that support that type of 
functionality either (at least I know Oracle does not).

thanks,
--Barry

Sunit Bhatia wrote:

> objects or data. e.g. If I'm storing a binary file in a row of a table, 
> I would want to see different versions of the same biary file. Everytime 
> I do a write, the version number should be bumped up !!
> 
> ---------------------------(end of broadcast)---------------------------
> TIP 4: Don't 'kill -9' the postmaster
>