Subject: Re: question on plain pg_dump file usage

From: Ron Johnson <[email-masked]>
Date: Tue, 17 Sep 2024 08:43:36 -0400

On Tue, Sep 17, 2024 at 8:22 AM Zwettler Markus (OIZ) <
[email-masked]> wrote:

> I have to do an out-of-place Postgres migration from PG12 to PG16 using:
>
>
>
> pg_dump -F p -f dump.sql …
>
> sed -i "s/old_name/new_name/g"
>
> psql -f dump.sql …
>
>
>
> Both databases are on UTF-8.
>
>
>
> I wonder if there could be character set conversion errors here, as the
> data is temporarily written to a plain text file.
>
>
Why must it be a plain text dump instead of a custom or directory dump?
Restoring to a new (and differently-named( database is perfectly doable.

-- 
Death to <Redacted>, and butter sauce.
Don't boil me, I'm still alive.
<Redacted> crustacean!

---

From: "Zwettler Markus (OIZ)" <[email-masked]>
Date: Tue, 17 Sep 2024 13:16:06 +0000

Von: Ron Johnson <[email-masked]>
Gesendet: Dienstag, 17. September 2024 14:44
An: PG-General Mailing List <[email-masked]>
Betreff: [Extern] Re: question on plain pg_dump file usage

On Tue, Sep 17, 2024 at 8:22 AM Zwettler Markus (OIZ) <[email-masked]<mailto:[email-masked]>> wrote:
I have to do an out-of-place Postgres migration from PG12 to PG16 using:

I wonder if there could be character set conversion errors here, as the data is temporarily written to a plain text file.

Why must it be a plain text dump instead of a custom or directory dump?  Restoring to a new (and differently-named( database is perfectly doable.

--- Externe Email: Vorsicht mit Anhängen, Links oder dem Preisgeben von Informationen ---

Because I can simply change the application from the old to the new structure then.

-Regards, Markus