Subject: Re: Delays between "connection received" and "connection authenticated" because of localhost entries in hba

From: Tom Lane <[email-masked]>
Date: Tue, 29 Oct 2024 13:06:12 -0400

"Daniel Westermann (DWE)" <[email-masked]> writes:
> we're facing a strange issue with delays between "connection received" and "connection authenticated".

> Has anyone experienced such a behavior? It seems clear that this is somehow related to name resolution but we couldn't reproduce something like this on the OS using dig (in a loop several hundred of times). It is also only happening from time to time, and not constantly.

FWIW, I do have vague memories of other complaints like this, although
not of whether solutions were found.  It was awhile ago though.
It might be worth searching our mailing list archives.

			regards, tom lane

---

From: "Daniel Westermann (DWE)" <[email-masked]>
Date: Tue, 29 Oct 2024 20:03:50 +0000

>It might be worth searching our mailing list archives.

I did that, but was not able to find anything useful related to this.

Regards
Daniel