Subject: Query editor window not appearing

From: "Seggie, Graeme" <[email-masked]>
Date: Fri, 7 Mar 2025 16:30:03 +0000

OFFICIAL

Hello,

I have recently upgraded my pgAdmin install on Windows 10 Enterprise to pgAdmin 4 v9.1. Having done so, when opening, my connections work for listing tables etc, but query editor will not open as a functioning window. It is listed as a title with Query History, Data Output, Messages and Notifications, but no way to enter text, load a file successfully (no error, just does not populate a window). I tried removing pgAdmin in the user area (roaming data etc as this resolved a previous issue with pgAdmin), but no luck this time. Is there a known issue like this affecting others?

Regards,
Graeme

OFFICIAL

---

From: Adrian Klaver <[email-masked]>
Date: Fri, 7 Mar 2025 08:33:58 -0800

On 3/7/25 08:30, Seggie, Graeme wrote:
> OFFICIAL
> 
> 
> Hello,
> 
> I have recently upgraded my pgAdmin install on Windows 10 Enterprise to 
> pgAdmin 4 v9.1. Having done so, when opening, my connections work for 
> listing tables etc, but query editor will not open as a functioning 
> window. It is listed as a title with Query History, Data Output, 
> Messages and Notifications, but no way to enter text, load a file 
> successfully (no error, just does not populate a window). I tried 
> removing pgAdmin in the user area (roaming data etc as this resolved a 
> previous issue with pgAdmin), but no luck this time. Is there a known 
> issue like this affecting others?

The solution:

https://www.postgresql.org/docs/current/app-psql.html

If that is not suitable then I would suggest asking here:

https://www.postgresql.org/list/pgadmin-support/

-- 
Adrian Klaver
[email-masked]

---

From: "Seggie, Graeme" <[email-masked]>
Date: Fri, 7 Mar 2025 16:51:26 +0000

OFFICIAL

Just to update on this, I realised the window is actually present, it just needs to be maximised or resized and then the results of a query (Data Output) have to be switched to or resized etc - quite a different default to what I was used to, that's all.

Graeme

OFFICIAL

From: Seggie, Graeme <[email-masked]>
Sent: 07 March 2025 16:30
To: [email-masked]
Subject: Query editor window not appearing

OFFICIAL

CAUTION: This email originated from outside the organisation. Do not click links or open attachments unless you recognise the sender and know the content is safe.

OFFICIAL

Hello,

Regards,
Graeme

OFFICIAL

OFFICIAL