Subject: set failover=true on existing logical replication slot PG18

From: Scot Kreienkamp <[email-masked]>
Date: Fri, 19 Jun 2026 15:24:49 +0000

Hello list,

I am trying to make use of the synchronized logical replication slots on PG18.  I have all the requirements met, and if I create a logical replication slot manually with failover=true it is replicated to the second node.  Unfortunately I have two connections that create their own logical replication slots with failover false.  AWS DMS is one for example, but both have the same problem.  Is there any way to change the failover parameter on an existing logical replication slot from false to true?  Or set it so that all logical replications slots are synchronized so that they don't have to be individually created or altered for replication=true?  Or force them all to true?  Any other ideas?

Thanks!

Scot Kreienkamp | Applications Infrastructure Architect | La-Z-Boy Corporate
(734) 384-6403 | 1-734-915-1444 | [email-masked]
One La-Z-Boy Drive | Monroe, Michigan 48162 | la-z-boy.com<http://www.la-z-boy.com/>
facebook.com/lazboy<http://facebook.com/lazboy>  | instagram.com/lazboy<https://instagram.com/lazboy> | youtube.com/lazboy<http://youtube.com/lazboy>

This message is intended only for the individual or entity to which it is addressed. It may contain privileged, confidential information which is exempt from disclosure under applicable laws. If you are not the intended recipient, you are strictly prohibited from disseminating or distributing this information (other than to the intended recipient) or copying this information. If you have received this communication in error, please notify us immediately by e-mail or by telephone at the above number. Thank you.

---

From: Matthew Tice <[email-masked]>
Date: Sat, 20 Jun 2026 06:16:36 -0600

> On Jun 19, 2026, at 9:24 AM, Scot Kreienkamp <[email-masked]> wrote:
> 
> Hello list,
>  
> I am trying to make use of the synchronized logical replication slots on PG18.  I have all the requirements met, and if I create a logical replication slot manually with failover=true it is replicated to the second node.  Unfortunately I have two connections that create their own logical replication slots with failover false.  AWS DMS is one for example, but both have the same problem.  Is there any way to change the failover parameter on an existing logical replication slot from false to true?  Or set it so that all logical replications slots are synchronized so that they don’t have to be individually created or altered for replication=true?  Or force them all to true?  Any other ideas?
>  
> Thanks!
>  

I had the same problem recently with our Confluent-generated replication slots.  I didn’t think there was but I just found this in the docs:

ALTER_REPLICATION_SLOT slot_name ( option [, ...] ) 
Change the definition of a replication slot. See Section 26.2.6 for more about replication slots. This command is currently only supported for logical replication slots.

slot_name
The name of the slot to alter. Must be a valid replication slot name (see Section 26.2.6.1).

The following option is supported:

FAILOVER [ boolean ]
If true, the slot is enabled to be synced to the standbys so that logical replication can be resumed after failover.

https://www.postgresql.org/docs/17/protocol-replication.html￼
53.4. Streaming Replication Protocol
postgresql.org

---

From: "Hayato Kuroda (Fujitsu)" <[email-masked]>
Date: Mon, 22 Jun 2026 05:44:15 +0000

Dear Matthew, Scot,

There are no ways to control default value of failover. Regarding the way for
changing the value, yes, ALTER_REPLICATION_SLOT replication command is an only
way to do that. Note that it's acceptable only when the backend is in the
replication mode - normal backend cannot understand them.

Best regards,
Hayato Kuroda
FUJITSU LIMITED

---

From: Scot Kreienkamp <[email-masked]>
Date: Mon, 22 Jun 2026 13:42:21 +0000

"normal backend cannot understand them."

Thank you Hayato, that's what I was missing.   I got it working now.

Scot Kreienkamp | Applications Infrastructure Architect | La-Z-Boy Corporate
One La-Z-Boy Drive | Monroe, Michigan 48162
|  (734) 384-6403 | 1-734-915-1444 | [email-masked]

-----Original Message-----

From: Hayato Kuroda (Fujitsu) <[email-masked]>

Sent: Monday, June 22, 2026 1:44 AM

To: 'Matthew Tice' <[email-masked]>

Cc: [email-masked]

Subject: RE: set failover=true on existing logical replication slot PG18

Dear Matthew, Scot,

Best regards,

Hayato Kuroda

FUJITSU LIMITED

This message is intended only for
the individual or entity to which it is addressed. It may contain privileged,
confidential information which is exempt from disclosure under applicable laws.
If you are not the intended recipient, you are strictly prohibited from
disseminating or distributing this information (other than to the intended
recipient) or copying this information. If you have received this communication
in error, please notify us immediately by e-mail or by telephone at the above
number. Thank you.