Subject: Re: pg_restore ERROR: permission denied to change default privileges

From: Rachel Roch <[email-masked]>
Date: Sun, 15 Jun 2025 10:06:40 +0200 (CEST)

14 Jun 2025, 16:21 by [email-masked]:

>
> Isn't fgrep -F redundant? As I understand it fgrep = grep -F
>
You have the wrong end of the stick. ;-)

As per Grep 3.8 release notes (https://lists.gnu.org/archive/html/info-gnu/2022-09/msg00001.html):

"The egrep and fgrep commands, which have been deprecated since  release 2.5.3 (2007), now warn that they are obsolescent and should  be replaced by grep -E and grep -F."

---

From: Adrian Klaver <[email-masked]>
Date: Sun, 15 Jun 2025 08:15:19 -0700

> You have the wrong end of the stick. ;-)

Don't think so, the -F is redundant.

Try grep -F then fgrep and then fgrep -F on the same file.

-- 
Adrian Klaver
[email-masked]

---

From: Adrian Klaver <[email-masked]>
Date: Sun, 15 Jun 2025 09:14:52 -0700

> Don't think so, the -F is redundant.

It is redundant for fgrep.
>> As per Grep 3.8 release notes 
>> (https://lists.gnu.org/archive/html/info-gnu/2022-09/msg00001.html):
>>
>> "The egrep and fgrep commands, which have been deprecated since  
>> release 2.5.3 (2007), now warn that they are obsolescent and should  
>> be replaced by grep -E and grep -F."
>>
>

---

From: Rachel Roch <[email-masked]>
Date: Mon, 16 Jun 2025 15:52:26 +0200 (CEST)

> It is redundant for fgrep.

Talk about muscle memory !  How many years have I still been typing fgrep -F thinking I was typing grep -F !