Subject: Some advice need after a 20 year gap after Ingres/GUIs

From: John Bateson <[email-masked]>
Date: Wed, 10 Apr 2024 10:11:21 +0000

Good morning,
The end of my working life was taken up with developing and supporting a Scientific Research establishment near Warrington in the UK. I had a small team of programmer who did an excellent job for me and with me.
The software was Ingres and the main program supporting user administration on a Synchrotron was built  under OpenROAD with other developments around the on-site stores and finance  using ABF since the stores workers found this much faster than a GUI! There was also some web development use .Net practises.
This was a quite complex system in the end with nearly 200 tables.
We ended up using Ingres Replicator with the intention of running it from two sites 180 miles apart - at the time it was a pile of notquitegoodenough! This was early this century so Actian may have made some improvements since then...

So much for the background to establish that I am not a complete newbie, just out of the loop for a while.

Using Postgres and PGAdmin -4.
So, 20 years later I am developing, (unpaid) a new project for some historic railways in the UK and linking these to the development and design of a range of kits for those interested in model railways. This is getting towards 20 tables so far.
What I really need is a recommendation for the current and best practice for an easy GUI that will allow me to press a button without opening up PGAdmin or a black screen, i.e. the traditional .EXE file I can put on a button on the screen on the screen on a Windows 11 based system.
While my programming history goes back to MDBS-4 and beyond I know I have some catching up to do and while not a complete newbie, need something I can work on quickly and intuitively and inexpensively!

So, recommendation and possibly some consensus would be very much appreciated.

And apologies if I have taken up too much of your time or have placed this in the wrong forum.

John

---

From: Francisco Prado <[email-masked]>
Date: Wed, 10 Apr 2024 09:38:07 -0400

Hi,

To start I had to find out what MDBS IV is, since it caught my attention 
and I ended up learning a few things about the history of databases ;-).

Regarding your concern:

First you must be clear that there are many alternatives to develop 
graphical interfaces to work with Postgres.

So, first of all:

  * You must choose and master a programming language that you feel
    comfortable with, Python is the one that most developers choose.
  * Use a development environment suitable for the language you have
    chosen, there are several, but the best known is possibly Visual
    Studio Code.
  * Choose which operating system you are going to develop with:
    Windows, Linux, macOS, generally most people choose Windows since
    you can integrate a Linux like Ubuntu using WSL.
  * After you master your favorite programming language, you must select
    a framework that allows you to generate a graphical interface, in
    Python there are several such as Tkinter, wxPython or Qt among others.
  * If the development is via the web, the options are many, the best
    known in Python would be Django for the web and FastAPI for the
    development of APIs via REST
  * You must also have a library that allows you to connect with
    Postgres, in Python there is pyODBC, psycopg2 among others.

Additional resources:

Python Tutorial: 
https://www.youtube.com/watch?v=eWRfhZUzrAc&list=PLWKjhJtqVAbnqBxcdjVGgT3uVR10bzTEB
Python & Tkinter: 
https://www.youtube.com/watch?v=yQSEXcf6s2I&list=PLCC34OHNcOtoC6GglhF3ncJ5rLwQrLGnV
Python & Postgres: https://www.youtube.com/watch?v=miEFm1CyjfM

Greetings and luck!

El 10/04/2024 a las 06:11, John Bateson escribió:
>
> Good morning,
>
> The end of my working life was taken up with developing and supporting 
> a Scientific Research establishment near Warrington in the UK. I had a 
> small team of programmer who did an excellent job for me and with me.
>
> The software was Ingres and the main program supporting user 
> administration on a Synchrotron was built  under OpenROAD with other 
> developments around the on-site stores and finance  using ABF since 
> the stores workers found this much faster than a GUI! There was also 
> some web development use .Net practises.
>
> We ended up using Ingres Replicator with the intention of running it 
> from two sites 180 miles apart – at the time it was a pile of 
> *notquitegoodenough*! This was early this century so Actian may have 
> made some improvements since then…
>
> So much for the background to establish that I am not a complete 
> newbie, just out of the loop for a while.
>
> *Using Postgres and PGAdmin -4*.
>
> So, 20 years later I am developing, (unpaid) a new project for some 
> historic railways in the UK and linking these to the development and 
> design of a range of kits for those interested in model railways. This 
> is getting towards 20 tables so far.
>
> What I really need is a recommendation for the current and best 
> practice for an easy GUI that will allow me to press a button without 
> opening up PGAdmin or a black screen, i.e. the traditional .EXE file I 
> can put on a button on the screen on the screen on a Windows 11 based 
> system.
>
> While my programming history goes back to MDBS-4 and beyond I know I 
> have some catching up to do and while not a complete newbie, need 
> something I can work on quickly and intuitively and inexpensively!
>
-- 
Saludos,

Francisco Prado