Subject: Quick Question!

From: Harry Yau <[email-masked]>
Date: Tue, 10 Jul 2001 17:14:55 +0800

Hi:
A really simple question: I wanna set up some WAL related config
parameter. I am wondering is it the same to add those parameter on
postgresql.conf as to add them on /etc/rc.d/init.d/postgres.init??

---

From: Adam Manock <[email-masked]>
Date: Tue, 10 Jul 2001 07:44:34 -0400

Hi,

I am about to put a 7.1.2 server into production on RedHat 7.1
The server will be dedicated to PostgreSQL, running a bare minimum of 
additional services.
If anyone has already tuned the configurable parameters on a dual PIII w/ 
1GB RAM then I
will have a great place to start for my performance tuning!
When I'm done I'll be posting my results here for the next first timer that 
comes along.

Thanks in advance,

Adam

---

From: Janning Vygen <[email-masked]>
Date: Tue, 10 Jul 2001 15:21:37 +0200

> will have a great place to start for my performance tuning!

i am running the same hardware and postgresql 7.1.2
but i didnt tuned it because its fast enough for my purpose. But i am very 
interested in your investigations. Could you please pm me, if you have 
something of interest?

thanks
janning

> ---------------------------(end of broadcast)---------------------------
> TIP 6: Have you searched our list archives?
>
> http://www.postgresql.org/search.mpl

-- 
Planwerk 6 /websolutions
Herzogstraße 86
40215 Düsseldorf

fon 0211-6015919
fax 0211-6015917
http://www.planwerk6.de

---

From: Philip Molter <[email-masked]>
Date: Tue, 10 Jul 2001 09:06:07 -0500

On Tue, Jul 10, 2001 at 07:44:34AM -0400, Adam Manock wrote:
: Hi,
: 
: I am about to put a 7.1.2 server into production on RedHat 7.1
: The server will be dedicated to PostgreSQL, running a bare minimum of 
: additional services.
: If anyone has already tuned the configurable parameters on a dual PIII w/ 
: 1GB RAM then I
: will have a great place to start for my performance tuning!
: When I'm done I'll be posting my results here for the next first timer that 
: comes along.

I have a similar system.  It's a dual PII-450MHz Xeon with 512MB of RAM
running RH7.1 and 7.1.2.  As far as performance tuning goes, here's the
relevant lines from the postgresql.conf file we're using:

  max_connections = 64 # 1-1024
  sort_mem = 8192
  shared_buffers = 192
  fsync = false

Obviously, depending on your needs, you can adjust those.  If you've
got a 1GB of RAM, I'd set everything high and not worry about it.

* Philip Molter
* DataFoundry.net
* http://www.datafoundry.net/
* [email-masked]

---

From: "Roderick A. Anderson" <[email-masked]>
Date: Tue, 10 Jul 2001 13:12:05 -0700 (PDT)

> When I'm done I'll be posting my results here for the next first timer that 

I've just did a quick read of Bruce's article in Linux Journal.  My take
is this is more than a hardware issue.  Table size, indexes (indices?)
verses sequential scans will come into play.  I don't think you can even
really test without some relevant data, queries, etc.
   Again this was a very quick read of the article.

Thanks Bruce.  It looks enlightening.

Cheers,
Rod
-- 
                 Remove the word 'try' from your vocabulary ... 
                     Don't try.  Do it or don't do it ...
                                Steers try!

                                                            Don Aslett

---

From: Justin Clift <[email-masked]>
Date: Wed, 11 Jul 2001 13:32:10 +1000

Hi all,

Just added these figures to a new document :

http://techdocs.postgresql.org/techdocs/perftuningfigures.php

As people provide/submit figures and details of the equipment they use,
I'll post them onto this page.

Hopefully it will become a good set of real world guidelines for people,
etc.

Standardised benchmarks would be nice to though.

:-)

Regards and best wishes,

Justin Clift

---

From: Adam Manock <[email-masked]>
Date: Thu, 12 Jul 2001 20:32:10 -0400

> Standardised benchmarks would be nice to though.
	Sure would be nice....

Here's some preliminary results of my testing...

System:	RedHat Linux 7.1, kernel 2.4.3smp (i686)
		Dual PIII 733 / 133FSB  1024MB RAM
		2 18Gb 10000rpm U160 SCSI drives, hardware RAID1
		
		added to /etc/sysctl.conf:
			kernel.shmmax = 268435456
			kernel.shmall = 268435456

PG 7.1.2	

postgresql-7.1.2-4PGDG binary rpm set
		
	relevant entries from postgresql.conf:
		max_connections = 32 	
		sort_mem = 4096
		shared_buffers = 32000
		fsync = true

The only benchmark I have is almost useless but I'll put it here anyway...

time ./pg_regress --schedule=parallel_schedule
(using postmaster on Unix socket, default port)
...
...
======================
  All 76 tests passed.
======================

real    0m40.784s
user    0m1.980s
sys     0m1.220s

Adam.