Subject: Re: Seeing new stuff in log after upgrading from 11 to 15

From: Tom Lane <[email-masked]>
Date: Wed, 15 May 2024 19:50:56 -0400

Dmitry O Litvintsev <[email-masked]> writes:
> After upgrade 11 -> 15 started to see these messages in hot standby log:

> < 2024-05-15 17:20:24.164 CDT  151879 > LOG:  restartpoint complete: wrote 296338 buffers (28.3%); 0 WAL file(s) added, 134 removed, 0 recycled; write=1619.469 s, sync=0.022 s, total=1619.539 s; sync files=1492, longest=0.002 s, average=0.001 s; distance=2195446 kB, estimate=4171347 kB
> < 2024-05-15 17:20:24.164 CDT  151879 > LOG:  recovery restart point at 17AB8/47000140
> < 2024-05-15 17:20:24.164 CDT  151879 > DETAIL:  Last completed transaction was at log time 2024-05-15 17:20:24.138362-05.
> < 2024-05-15 17:20:24.167 CDT  151879 > LOG:  restartpoint starting: wal

> while running 11 the log was almost empty, and I did not modify verbosity settings... 
> Queston : are above harmless and just informational?

This is checkpoint logging, which is on by default now (a decision
I didn't particularly approve of).  Feel free to set
"log_checkpoints = off" if you don't want it.

			regards, tom lane

---

From: Dmitry O Litvintsev <[email-masked]>
Date: Thu, 16 May 2024 00:00:36 +0000

Thanks for the quick reply! NP, I was just being extra cautious after upgrade.

________________________________________
From: Tom Lane <[email-masked]>
Sent: Wednesday, May 15, 2024 6:50 PM
To: Dmitry O Litvintsev
Cc: [email-masked]
Subject: Re: Seeing new stuff in log after upgrading from 11 to 15

[EXTERNAL] – This message is from an external sender

                        regards, tom lane