Subject: Re: timescaledb vs NULL vs pg_timeseries vs partman + pgcron + pg_ivm

From: Amitabh Kant <[email-masked]>
Date: Wed, 9 Apr 2025 07:20:56 +0530

On Tue, Apr 8, 2025 at 11:29 PM Achilleas Mantzios <
[email-masked]> wrote:

>
> On 8/4/25 20:37, Amitabh Kant wrote:
>
> On Tue, Apr 8, 2025 at 9:40 PM Achilleas Mantzios - cloud <
> [email-masked]> wrote:
>
>> Hi
>> <snip>
>> timescaledb seemed mature, but also exotic, allow me the term. No way to
>> use native logical replication, shortage of options to run on premise or
>> self hosted, which leaves us with those options :
>>
>> <snip>
>>
>>
> I cannot comment on the applicability of timescaledb in your context, but
> running it on premise/self-hosted has posed no problems, at least on
> Debian.
>
> If I understood your query incorrectly, please ignore.
>
> Thank you, I meant the paid/supported service not the community version.
> Which of the two do you use?
>
>
>
I use the community version.

---

From: Achilleas Mantzios - cloud <[email-masked]>
Date: Wed, 9 Apr 2025 09:20:37 +0300

On 4/9/25 04:50, Amitabh Kant wrote:
>
>     Thank you, I meant the paid/supported service not the community
>     version. Which of the two do you use?
>>

On 4/9/25 05:23, Brent Wood wrote:

> I also use the free community edition on internal servers, but under 
> Ubuntu. No issues and very good performance.
>
> Brent Wood...
>

Thanks Amitabh abd Brent, how do you plan to cope with future upgrades 
based on logical replication ? Do you run timescale on a 
dedicated/separate system from the rest of your PostgreSQL cluster(s)?

---

From: Amitabh Kant <[email-masked]>
Date: Thu, 10 Apr 2025 10:55:19 +0530

On Wed, Apr 9, 2025 at 11:50 AM Achilleas Mantzios - cloud <
[email-masked]> wrote:

> based on logical replication ? Do you run timescale on a dedicated/separate
> system from the rest of your PostgreSQL cluster(s)?
>

I don't use the inbuilt logical replication. I depend upon pgBackRest for
my backups. My database is mainly time series data, and runs on the same
systems.

---

From: Achilleas Mantzios <[email-masked]>
Date: Thu, 10 Apr 2025 15:17:27 +0300

Hi Brent

how do you plan to cope with future upgrades based on logical 
replication ? Do you run timescale on a dedicated/separate system from 
the rest of your PostgreSQL cluster(s)?

On 10/4/25 08:25, Amitabh Kant wrote:
> On Wed, Apr 9, 2025 at 11:50 AM Achilleas Mantzios - cloud 
> <[email-masked]> wrote:
>
>
>>         Thank you, I meant the paid/supported service not the
>>         community version. Which of the two do you use?
>>>
>>     I also use the free community edition on internal servers, but
>>     under Ubuntu. No issues and very good performance.
>>
>>     Brent Wood...
>>
>
>     Thanks Amitabh abd Brent, how do you plan to cope with future
>     upgrades based on logical replication ? Do you run timescale on a
> I don't use the inbuilt logical replication. I depend upon pgBackRest 
> for my backups. My database is mainly time series data, and runs on 
> the same systems.
thanks

---

From: Brent Wood <[email-masked]>
Date: Sat, 12 Apr 2025 21:21:49 +0000

Our Timescale dbs are on individual hosts, separate from our main Postgres servers.

So standalone systems to be upgraded individually as required.

Brent Wood

Principal Technician, Fisheries
NIWA
DDI:  +64 (4) 3860529
________________________________
From: Achilleas Mantzios <[email-masked]>
Sent: Friday, April 11, 2025 00:17
To: [email-masked] <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: Re: timescaledb vs NULL vs pg_timeseries vs partman + pgcron + pg_ivm

Hi Brent

how do you plan to cope with future upgrades based on logical replication ? Do you run timescale on a dedicated/separate system from the rest of your PostgreSQL cluster(s)?

On 10/4/25 08:25, Amitabh Kant wrote:
On Wed, Apr 9, 2025 at 11:50 AM Achilleas Mantzios - cloud <[email-masked]<mailto:[email-masked]>> wrote:

On 4/9/25 04:50, Amitabh Kant wrote:
Thank you, I meant the paid/supported service not the community version. Which of the two do you use?

I also use the free community edition on internal servers, but under Ubuntu. No issues and very good performance.

Brent Wood...

Thanks Amitabh abd Brent, how do you plan to cope with future upgrades based on logical replication ? Do you run timescale on a dedicated/separate system from the rest of your PostgreSQL cluster(s)?

I don't use the inbuilt logical replication. I depend upon pgBackRest for my backups. My database is mainly time series data, and runs on the same systems.
thanks
[https://www.niwa.co.nz/static/niwa-2018-horizontal-180.png] <https://www.niwa.co.nz>
Brent Wood
Principal Technician - GIS and Spatial Data Management
Programme Leader - Environmental Information Delivery
+64-4-386-0529

National Institute of Water & Atmospheric Research Ltd (NIWA)
301 Evans Bay Parade Hataitai Wellington New Zealand
Connect with NIWA: niwa.co.nz<https://www.niwa.co.nz> Facebook<https://www.facebook.com/nzniwa> LinkedIn<https://www.linkedin.com/company/niwa> Twitter<https://twitter.com/niwa_nz> Instagram<https://www.instagram.com/niwa_science> YouTube<https://www.youtube.com/channel/UCJ-j3MLMg1H59Ak2UaNLL3A>
To ensure compliance with legal requirements and to maintain cyber security standards, NIWA's IT systems are subject to ongoing monitoring, activity logging and auditing. This monitoring and auditing service may be provided by third parties. Such third parties can access information transmitted to, processed by and stored on NIWA's IT systems.
Note: This email is intended solely for the use of the addressee and may contain information that is confidential or subject to legal professional privilege. If you receive this email in error please immediately notify the sender and delete the email.

---

From: Achilleas Mantzios <[email-masked]>
Date: Sun, 13 Apr 2025 08:13:41 +0300

Thank you Brent and Amitabh

On 13/4/25 00:21, Brent Wood wrote:
> ------------------------------------------------------------------------
> *From:* Achilleas Mantzios <[email-masked]>
> *Sent:* Friday, April 11, 2025 00:17
> *To:* [email-masked] <[email-masked]>
> *Cc:* [email-masked] 
> <[email-masked]>
> *Subject:* Re: timescaledb vs NULL vs pg_timeseries vs partman + 
> pgcron + pg_ivm
>
> Hi Brent
>
>> <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>>
>>
> <https://www.niwa.co.nz> 	Brent Wood
> *Connect with NIWA:* niwa.co.nz <https://www.niwa.co.nz> Facebook 
> <https://www.facebook.com/nzniwa> LinkedIn 
> <https://www.linkedin.com/company/niwa> Twitter 
> <https://twitter.com/niwa_nz> Instagram 
> <https://www.instagram.com/niwa_science> YouTube 
> <https://www.youtube.com/channel/UCJ-j3MLMg1H59Ak2UaNLL3A>
>
> To ensure compliance with legal requirements and to maintain cyber 
> security standards, NIWA's IT systems are subject to ongoing 
> monitoring, activity logging and auditing. This monitoring and 
> auditing service may be provided by third parties. Such third parties 
> can access information transmitted to, processed by and stored on 
> NIWA's IT systems.
> Note: This email is intended solely for the use of the addressee and 
> may contain information that is confidential or subject to legal 
> professional privilege. If you receive this email in error please 
> immediately notify the sender and delete the email.