Subject: Re: Request for official clarification on SQL parameter parsing changes in PostgreSQL 15 and 16

From: Tom Lane <[email-masked]>
Date: Thu, 17 Apr 2025 10:15:52 -0400

Laurenz Albe <[email-masked]> writes:
> On Thu, 2025-04-17 at 05:17 +0000, 王　博 wrote:
>> 1. In PostgreSQL 15 and later:
>>    The following SQL causes a syntax error unless a space is added after the `?`:
>>      SELECT * FROM table WHERE a = ?AND b = 123;
>>    → Adding a space (`? AND`) resolves the issue.

> I'd say it is this change:
> https://postgr.es/c/2549f0661bd28571d7200d6f82f752a7ee5d47e1

Yeah.  This looks like "?" ought to be parsable as a separate token
... but as Dominique noted, it's not actually legal syntax in any
version of Postgres.  Something in your client stack must be
translating "?" to "$1", "$2", etc, and so the new prohibition
against junk trailing a number applies.

You could fix this without application-level changes if you fixed
whatever is making that substitution to add spaces around the
parameter symbol.  It's really a bug that it didn't do so already,
since closely-adjacent cases like digits immediately after the
"?" would already have caused failures.

			regards, tom lane

---

From: 王 博 <[email-masked]>
Date: Fri, 18 Apr 2025 01:38:42 +0000

Dear Tom, Laurenz, and Dominique,

Thank you all very much for your helpful and detailed explanations.

Your insights clarified the behavior change in PostgreSQL 15 perfectly, and I now have a clear understanding of the issue I was encountering. I really appreciate your time and support.

Best regards,  
Wang Bo

-----Original Message-----
From: Tom Lane <[email-masked]> 
Sent: Thursday, April 17, 2025 11:16 PM
To: Laurenz Albe <[email-masked]>
Cc: 王　博 <[email-masked]>; [email-masked]; 李　浩 <[email-masked]>
Subject: Re: Request for official clarification on SQL parameter parsing changes in PostgreSQL 15 and 16

> https://postgr.es/c/2549f0661bd28571d7200d6f82f752a7ee5d47e1

Yeah.  This looks like "?" ought to be parsable as a separate token ... but as Dominique noted, it's not actually legal syntax in any version of Postgres.  Something in your client stack must be translating "?" to "$1", "$2", etc, and so the new prohibition against junk trailing a number applies.

You could fix this without application-level changes if you fixed whatever is making that substitution to add spaces around the parameter symbol.  It's really a bug that it didn't do so already, since closely-adjacent cases like digits immediately after the "?" would already have caused failures.

			regards, tom lane