Subject: Re: Hello, how should I fix it?

From: Adrian Klaver <[email-masked]>
Date: Sun, 13 Oct 2024 09:04:36 -0700

On 10/13/24 05:57, 吴 其键 wrote:
> service postgresql start
> Starting PostgreSQL 16 database server: mainError: 
> /usr/lib/postgresql/16/bin/pg_ctl /usr/lib/postgresql/16/bin/pg_ctl 
> start -D /var/lib/postgresql/16/main -l 
> /var/log/postgresql/postgresql-16-main.log -s -o  -c 
> config_file="/etc/postgresql/16/main/postgresql.conf"  exited with status 1:
> 2024-10-13 12:55:21.553 UTC [16727] FATAL:  could not create shared 
> memory segment: Function not implemented
> 2024-10-13 12:55:21.553 UTC [16727] DETAIL:  Failed system call was 
> shmget(key=6644951, size=56, 03600).
> 2024-10-13 12:55:21.553 UTC [16727] LOG:  database system is shut down
> pg_ctl: could not start server
> Examine the log output. ... failed!
>   failed!
> 

Need more information:

1) Exact Postgres version, so 16.x.

2) OS and version.

3) Where did you get the Postgres package from?

> 获取Outlook for Android <https://aka.ms/AAb9ysg>

-- 
Adrian Klaver
[email-masked]

---

From: Erik Wienhold <[email-masked]>
Date: Sun, 13 Oct 2024 18:27:45 +0200

> 1) Exact Postgres version, so 16.x.

Also good to know if this is running in a virtualized environment that
does not allow or support SysV IPC.

-- 
Erik

---

From: 吴 其键 <[email-masked]>
Date: Mon, 14 Oct 2024 04:21:11 +0000

I am running in Kali NetHunter chroot, using the official Kali apt repository to install PostgreSQL 16.4.

获取Outlook for Android<https://aka.ms/AAb9ysg>
________________________________
From: Erik Wienhold <[email-masked]>
Sent: Monday, October 14, 2024 12:27:45 AM
To: Adrian Klaver <[email-masked]>
Cc: 吴 其键 <[email-masked]>; [email-masked] <[email-masked]>
Subject: Re: Hello, how should I fix it?

--
Erik

---

From: Bruce Momjian <[email-masked]>
Date: Mon, 14 Oct 2024 13:00:24 -0400

> to install PostgreSQL 16.4.

The error is pretty clear that that configuation, either the operating
system or chroot, does not support shared memory.

---------------------------------------------------------------------------

> 
> 获取Outlook for Android
> ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
> Cc: 吴其键 <[email-masked]>; [email-masked]
> <[email-masked]>
> > On 10/13/24 05:57, 吴其键 wrote:
> > > service postgresql start

-- 
  Bruce Momjian  <[email-masked]>        https://momjian.us
  EDB                                      https://enterprisedb.com

  When a patient asks the doctor, "Am I going to die?", he means 
  "Am I going to die soon?"