Subject: Re: Interesting case of IMMUTABLE significantly hurting performance

From: Laurenz Albe <[email-masked]>
Date: Fri, 11 Apr 2025 07:15:44 +0200

On Thu, 2025-04-10 at 22:18 -0500, Merlin Moncure wrote:
> Facts.  This is black magic.   This has come up over and over. 

Perhaps it would help to add the excellent information from the Wiki to the documentation:
https://wiki.postgresql.org/wiki/Inlining_of_SQL_functions

Yours,
Laurenz Albe

---

From: Nico Williams <[email-masked]>
Date: Fri, 11 Apr 2025 00:30:38 -0500

> https://wiki.postgresql.org/wiki/Inlining_of_SQL_functions

Adding a warning in the functions _docs_ to check their various
attributes in the cataclog would suffice.