Subject: psql meta command

From: Marc Millas <[email-masked]>
Date: Thu, 10 Apr 2025 14:29:06 +0200

Hello,

on a customer postgres db, using psql, if I post \  to initiate, for
exemple \x
that psql immediately exits.
somewhat boring as it blocks all psql meta commands.
Is there a way to get the extended display without posting a \  ?

thanks,

Marc MILLAS
Senior Architect
+33607850334
www.mokadb.com

---

From: Christoph Moench-Tegeder <[email-masked]>
Date: Fri, 11 Apr 2025 00:41:24 +0200

> that psql immediately exits.

I've seen that happen with broken terminals, mostly some "web shell"
stuff. Ditch that, it's most likely broken in other ways, too.

> Is there a way to get the extended display without posting a \  ?

If you can live with expanded mode being constantly on, start psql
with parameter -x as in "--expanded".

Regards,
Christoph

-- 
Spare Space