Subject: Re: create_immv issue on aws Ubuntu even after create extention

From: Krishnakant Mane <[email-masked]>
Date: Fri, 28 Feb 2025 22:31:53 +0530

Ok here you go.

select create_immv('plantskillpayment', 'select distinct kwapp_plant.id 
as plantid, kwapp_skill.id as skillid, kwapp_skill.skillname, 
kwapp_plant.plantname, kwapp_pltsklpaylvl.level, kwapp_pltsklpaylvl.pay 
from kwapp_skill, kwapp_plant,  kwapp_pltsklpaylvl  where 
kwapp_skill.id  = kwapp_pltsklpaylvl.skillid_id  and kwapp_plant.id = 
kwapp_pltsklpaylvl.plantid_id');

You see, the point is this works perfectly on all local machines with 
exact same versions and same data.

Regards.

On 2/28/25 22:24, Ron Johnson wrote:
> On Fri, Feb 28, 2025 at 11:41 AM Krishnakant Mane 
> <[email-masked]> wrote:
>
>     Hello all.
>
>     I am not able to use create_immv in postgresql 16.6 even after
>     installing it and doing create extention.
>
>     I did a git clone of the repository and then make sudo make
>     install to install it.
>
>     The issue is not happening on my local ubuntu 24.04 machine but on
>     ubuntu 24.04 on aws free tier.
>
>     All dependencies are in place, that's why the extention got
>     installed in the first place.
>
>     I get the error "function create_immv(unknown, unknown) does not
>     exist.
>
>     all the tables related to this view exist, data is present and
>     same setup works perfectly on my local machine, same OS and
>     postgresql version.
>
>     Can someone suggest what could be the solution?
>
> Show your work!
>
> What command did you run to get that error?
>
> -- 
> Death to <Redacted>, and butter sauce.
> Don't boil me, I'm still alive.
> <Redacted> lobster!
-- 
Email Signature
*Krishnakant Mane*
Software Architecture Design & Implementation Specialist 	

Mobile: 	
	+91 8424039903

https://www.linkedin.com/in/krishnakant-r-mane/

---

From: Ron Johnson <[email-masked]>
Date: Fri, 28 Feb 2025 12:23:22 -0500

Differing search_path values can lead to problems like this.

On Fri, Feb 28, 2025 at 12:01 PM Krishnakant Mane <[email-masked]>
wrote:

> from kwapp_skill, kwapp_plant,  kwapp_pltsklpaylvl  where kwapp_skill.id
> = kwapp_pltsklpaylvl.skillid_id  and kwapp_plant.id =
> On Fri, Feb 28, 2025 at 11:41 AM Krishnakant Mane <[email-masked]>
> wrote:
>
>> Hello all.
>>
>> I am not able to use create_immv in postgresql 16.6 even after installing
>> it and doing create extention.
>>
>> I did a git clone of the repository and then make sudo make install to
>> install it.
>>
>> The issue is not happening on my local ubuntu 24.04 machine but on ubuntu
>> 24.04 on aws free tier.
>>
>> All dependencies are in place, that's why the extention got installed in
>> the first place.
>>
>> I get the error "function create_immv(unknown, unknown) does not exist.
>>
>> all the tables related to this view exist, data is present and same setup
>> works perfectly on my local machine, same OS and postgresql version.
>>

---

From: Krishnakant Mane <[email-masked]>
Date: Fri, 28 Feb 2025 22:56:52 +0530

> Differing search_path values can lead to problems like this.
So what can I do to resolve this?
> On Fri, Feb 28, 2025 at 12:01 PM Krishnakant Mane 
>     select create_immv('plantskillpayment', 'select distinct
>     kwapp_plant.id <http://kwapp_plant.id> as plantid, kwapp_skill.id
>     <http://kwapp_skill.id> as skillid, kwapp_skill.skillname,
>     kwapp_plant.plantname, kwapp_pltsklpaylvl.level,
>     kwapp_pltsklpaylvl.pay from kwapp_skill, kwapp_plant,
>     kwapp_pltsklpaylvl  where kwapp_skill.id <http://kwapp_skill.id> 
>     = kwapp_pltsklpaylvl.skillid_id  and kwapp_plant.id
>     <http://kwapp_plant.id> = kwapp_pltsklpaylvl.plantid_id');
>
>
>     You see, the point is this works perfectly on all local machines
>     with exact same versions and same data.
>
>     Regards.
>
>>         I am not able to use create_immv in postgresql 16.6 even
>>         after installing it and doing create extention.
>>
>>         The issue is not happening on my local ubuntu 24.04 machine
>>         but on ubuntu 24.04 on aws free tier.
>>
>>         all the tables related to this view exist, data is present
>>         and same setup works perfectly on my local machine, same OS
>>         and postgresql version.
>>

Mobile: 	
	+91 8424039903