Subject: Re: Issue Launching PostgreSQL on MacBook M4 – Error -10669‏

From: "Philipp Defner" <[email-masked]>
Date: Fri, 09 May 2025 13:42:56 +0800

Hey, please use "Reply All" when you reply (As someone else already told you before I saw), as otherwise the response only goes to me directly and nobody else can follow along or help you.

After a quick online search it seems that this error means you don't have Rosetta installed, this is the emulation layer that Apple provides to run Apps built for Intel on Apple Silicon Mac.

If you run this in your Terminal, it might not say "rosetta installed": "if /usr/bin/pgrep -q oahd; then echo 'rosetta installed'; fi"

I'd try Postgres.app from the download page I mentioned, or install Rosetta: "`/usr/sbin/softwareupdate --install-rosetta --agree-to-license"`

On Fri, May 9, 2025, at 1:31 PM, איתי זרחוביץ wrote:
> Hey,
> I tried to install PostrgreSQL,version 17.5 via https://www.postgresql.org/download/macosx/.
> When the download was complete, the application opened. I clicked 'next' to process and finish the installation, and finally, when I tried to open the application,
> it showed me this error:
> _LSOpenURLsWithCompletionHandler() failed with error -10669 (1)
> I also tried to install version 16.9 and I got the same error
> 
> ‫בתאריך יום ו׳, 9 במאי 2025 ב-8:12 מאת ‪Philipp Defner‬‏ <‪[email-masked]‬‏>:‬
>> __
>> Hey, you'll need to give a bit more information here. How did you install Postgres and what are you doing to see this error message?
>> 
>> There's multiple ways recommended on https://www.postgresql.org/download/macosx/, personally I'd give Postgres.app a. try or the installation via Homebrew (A bit less easy than the GUI app)
>> 
>> Philipp
>> 
>> On Thu, May 8, 2025, at 8:17 PM, איתי זרחוביץ wrote:
>>> ,Hello
>>> I have a MacBook with an M4 chip. I tried installing PostgreSQL version 17.5, but after the 
>>> installation, I received the following error
>>> _LSOpenURLsWithCompletionHandler() failed with error -10669 (1)
>>> .and the application fails to launch
>>> 
>>> A screenshot of the error is attached for reference 
>>> 
>>> 
>>> 
>>> 
>>> .I also tried installing older versions, but encountered the same error
>>> I contacted Apple Support, and they confirmed that my device is working properly
>>> 
>>> 
>>> Your software is very important for my studies, and I would greatly appreciate your help in resolving this issue
>>> 
>>> Thanks,
>>> 
>>> Etay
>>> 
>>> 
>>> *Attachments:*
>>>  • WhatsApp Image 2025-05-07 at 08.23.48.jpeg
>>

---

From: איתי זרחוביץ <[email-masked]>
Date: Fri, 9 May 2025 08:57:26 +0300

Ok
So, in order to install it well, what are the steps that i need to take
from the beginning?
I already have the application on my Mac but it doesn’t want

On Fri, 9 May 2025 at 8:43 Philipp Defner <[email-masked]> wrote:

> Hey, please use "Reply All" when you reply (As someone else already told
> you before I saw), as otherwise the response only goes to me directly and
> nobody else can follow along or help you.
>
> After a quick online search it seems that this error means you don't have
> Rosetta installed, this is the emulation layer that Apple provides to run
> Apps built for Intel on Apple Silicon Mac.
>
> If you run this in your Terminal, it might not say "rosetta installed":
> "if /usr/bin/pgrep -q oahd; then echo 'rosetta installed'; fi"
>
> I'd try Postgres.app from the download page I mentioned, or install
> Rosetta: "/usr/sbin/softwareupdate --install-rosetta --agree-to-license"
>
> I tried to install PostrgreSQL,version 17.5 via
> https://www.postgresql.org/download/macosx/.
> When the download was complete, the application opened. I clicked 'next'
> to process and finish the installation, and finally, when I tried to open
> the application,
> it showed me this error:
> Hey, you'll need to give a bit more information here. How did you install
> Postgres and what are you doing to see this error message?
>
> There's multiple ways recommended on
> https://www.postgresql.org/download/macosx/, personally I'd
> give Postgres.app a. try or the installation via Homebrew (A bit less easy
> than the GUI app)
>
> Philipp
>
> Your software is very important for my studies, and I would greatly
> appreciate your help in resolving this issue
>
> Thanks,
>
> Etay
>
> *Attachments:*
>
>    - WhatsApp Image 2025-05-07 at 08.23.48.jpeg
>
>
>
>

---

From: "Philipp Defner" <[email-masked]>
Date: Fri, 09 May 2025 14:11:28 +0800

Go to https://postgresapp.com/downloads.html, download the app, install and connect to the running instance with your Postgres GUI client of choice. If it's an important part of your studies you should be able to figure out to get it running too.

The error message you originally shared isn't a Postgres issue but a macOS issue.

On Fri, May 9, 2025, at 1:57 PM, איתי זרחוביץ wrote:
> Ok
> So, in order to install it well, what are the steps that i need to take from the beginning?

---

From: איתי זרחוביץ <[email-masked]>
Date: Fri, 9 May 2025 11:20:14 +0300

Thanks, I will!

On Fri, 9 May 2025 at 9:11 Philipp Defner <[email-masked]> wrote:

> Go to https://postgresapp.com/downloads.html, download the app, install
> and connect to the running instance with your Postgres GUI client of
> choice. If it's an important part of your studies you should be able to
> figure out to get it running too.
>