Subject: Re: UTC is not a time zone?

From: Adrian Klaver <[email-masked]>
Date: Mon, 13 May 2024 10:48:20 -0700

On 5/13/24 10:37 AM, Christophe Pettus wrote:
> PostgreSQL 16.3 on MacOS Sonoma.  A long-running process (which held a connection open the entire time) failed with:
> 
> 2024-05-13 09:12:44.719 PDT,"cyan","cyan",35926,"[local]",664214f9.8c56,3,"SELECT",2024-05-13 06:26:17 PDT,3/444460,0,ERROR,22023,"invalid value for parameter ""TimeZone"": ""UTC""",,,,,"while setting parameter ""TimeZone"" to ""UTC""
> parallel worker","  select count(1), count(1) filter (where visited > 0) from framework_seenchoice  ",,,"","client backend",,0
> 
> It's not (easily) repeatable, and the system was not touched while the process was running (no installing new binaries, etc.).  Does this look familiar to anyone?
> 

Yes:

https://www.postgresql.org/message-id/5DF49366-10D1-42A4-99BF-F9A7DC3AB0F4%40mailbox.org

Answer:

https://www.postgresql.org/message-id/1273542.1712326418%40sss.pgh.pa.us

-- 
Adrian Klaver
[email-masked]

---

From: Christophe Pettus <[email-masked]>
Date: Mon, 13 May 2024 10:50:26 -0700

> On May 13, 2024, at 10:48, Adrian Klaver <[email-masked]> wrote:
> Yes:
> 

Thanks!  Similar, but I don't think it's that.  This was a sudden change in a long-running connection that had issued a ton of ` SET TIMEZONE TO 'UTC'; ` before the failure.

---

From: Adrian Klaver <[email-masked]>
Date: Mon, 13 May 2024 10:58:42 -0700

> Thanks!  Similar, but I don't think it's that.  This was a sudden change in a long-running connection that had issued a ton of ` SET TIMEZONE TO 'UTC'; ` before the failure.

You sure the timezone file did not get changed under the connection?

Why is SET TIMEZONE TO 'UTC being constantly called?

---

From: Christophe Pettus <[email-masked]>
Date: Mon, 13 May 2024 11:02:13 -0700

> On May 13, 2024, at 10:58, Adrian Klaver <[email-masked]> wrote:
> 

Yes (at least, nothing happened on the system that would indicate that).  The system wasn't touched during the execution (and, as noted, it worked after as well as before).

> Why is SET TIMEZONE TO 'UTC being constantly called?

ORM noise.