Subject: Re: Performance issues during pg_restore -j with big partitioned table

From: Adrian Klaver <[email-masked]>
Date: Fri, 4 Apr 2025 08:02:43 -0700

On 4/4/25 06:13, Dimitrios Apostolou wrote:
> On Wed, 2 Apr 2025, Dimitrios Apostolou wrote:
> 

> Bug? This happened on a postgres compiled from last week's master branch.

Are you talking about the dev version?

> The dump I'm trying to restore is from postgres 17.4.
> 
> 
> Thanks
> Dimitris
> 
> 
> 

-- 
Adrian Klaver
[email-masked]

---

From: Dimitrios Apostolou <[email-masked]>
Date: Fri, 4 Apr 2025 17:09:14 +0200 (CEST)

> Are you talking about the dev version?

In this thread, yes. My mistake I didn't mention it from the start. I
compiled it in order to see if the problems I mentioned in my previous
thread were fixed.

Dimitris

---

From: Adrian Klaver <[email-masked]>
Date: Fri, 4 Apr 2025 08:23:35 -0700

> compiled it in order to see if the problems I mentioned in my previous

Since it still has not established that an actual problem exists in 
previous versions, this is premature. Especially as dev has not even 
reached alpha AFAIK.

To get at a solution more detailed information is needed. I would also 
suggest testing using something less the 1000 large partitions.

Information needed for any given report:

1) Postgres version being dumped from.

2) The complete pg_dump command.

3) The Postgres version being restored to.

4) The complete pg_restore command.

5) The error messages.

Also have you tried a schema only dump/restore?