Subject: Re: Windows installation problem at post-install step

From: Ertan Küçükoglu <[email-masked]>
Date: Sun, 21 Jul 2024 20:21:34 +0300

Adrian Klaver <[email-masked]>, 21 Tem 2024 Paz, 20:04 tarihinde
şunu yazdı:

> On 7/21/24 09:16, Ertan Küçükoglu wrote:
> > Hello,
> >
> > I am trying to install posgreql-16.3-2-windows-x64.exe on Windows 10
> > English VM with all updates installed and up to date.
>
> What is the host OS and version?
>
> What is the locale in the VM?

Host OS is Windows 11 English. Display language is English. Country is
Türkiye and everything else is set to US English.
I am trying to install PostgreSQL on Windows 10 64bit English. Everything
including the country on the guest OS is also set to US English.

Thanks & Regards,
Ertan

---

From: Adrian Klaver <[email-masked]>
Date: Sun, 21 Jul 2024 10:34:19 -0700

On 7/21/24 10:21, Ertan Küçükoglu wrote:
> Adrian Klaver <[email-masked] 
> <mailto:[email-masked]>>, 21 Tem 2024 Paz, 20:04 tarihinde 
> şunu yazdı:
> 
> I am trying to install PostgreSQL on Windows 10 64bit English. 
> Everything including the country on the guest OS is also set to US English.

What happens if you set the VM to Türkiye and install?

-- 
Adrian Klaver
[email-masked]

---

From: Ertan Küçükoglu <[email-masked]>
Date: Sun, 21 Jul 2024 20:52:22 +0300

Adrian Klaver <[email-masked]>, 21 Tem 2024 Paz, 20:34 tarihinde

> What happens if you set the VM to Türkiye and install?

Problem still exists even if I set everything to Türkiye and Turkish.
1- I tried to manually select default locale to "Turkey, Türkiye"
2- I tried to install using [Default locale]
both of above fails and both installation log files have identical wrong
text "Turkish_T rkiye.1254"

Thanks & Regards,
Ertan

---

From: Adrian Klaver <[email-masked]>
Date: Sun, 21 Jul 2024 11:48:01 -0700

On 7/21/24 10:52, Ertan Küçükoglu wrote:
> <mailto:[email-masked]>>, 21 Tem 2024 Paz, 20:34 tarihinde 
> şunu yazdı:
> 
> 

I don't know enough about Windows locales and the EDB installer to be of 
further help in that direction.

Is it feasible to install a Linux VM and install Postgres there?

---

From: Ertan Küçükoglu <[email-masked]>
Date: Sun, 21 Jul 2024 22:00:33 +0300

Adrian Klaver <[email-masked]>, 21 Tem 2024 Paz, 21:48 tarihinde

> Is it feasible to install a Linux VM and install Postgres there?

My main purpose was and still is to reach EDB people using the forum and
let them know about the problem.
I believe it is something to be fixed for future installations. I would
like to provide additional information if needed.

On the other hand, I have a backup taken on another Windows system that I
need to restore after installation.
I am not sure if it will be restored without any issues if I am to use a
Linux VM. I will try.

Thanks for the help.

Regards,
Ertan