Subject: Re: Feature Proposal: Column-Level DELETE Operation in SQL

From: Karsten Hilbert <[email-masked]>
Date: Tue, 22 Apr 2025 14:26:07 +0200

Am Mon, Apr 21, 2025 at 10:23:30PM +0530 schrieb Abhishek Hatgine:

>    *deleting* a value is conceptually different from *updating* it to NULL.

In what way ?

In other words, you'll have to much better define what you
mean be "deleting a value".

DROP COLUMN already exists, for that matter.

Updating a column to its DEFAULT value may also be closer to
what you envision a "column-delete" to do.

Karsten
-- 
GPG  40BE 5B0E C98E 1713 AFA6  5BC0 3BEA AC80 7D4F C89B

---

From: Amul Sul <[email-masked]>
Date: Tue, 22 Apr 2025 18:58:39 +0530

> what you envision a "column-delete" to do.

Agreed, this is a much better approach to achieve the same.

I am a bit skeptical about whether the proposed syntax will be
acceptable if it's not SQL standard, unless it's absolutely necessary
to support functionality that can't be achieved with the existing
syntax which is not the case here.

Regards,
Amul