Subject: Re: Clarification on Role Access Rights to Table Indexes

From: Nathan Bossart <[email-masked]>
Date: Wed, 15 Oct 2025 10:39:17 -0500

On Tue, Oct 14, 2025 at 10:01:37AM -0700, Jeff Davis wrote:
> If we start with an OID, what's the right way to do these kinds of
> checks? Could we do an ACL check, then lock it, then do an ACL check
> again to catch OID wraparound?

I tried something like this upthread [0].  My feeling was that this was a
lot of complexity for not a lot of gain.  Perhaps it's still worth doing,
though.

[0] https://postgr.es/m/aOgmi6avE6qMw_6t%40nathan

-- 
nathan

---

From: Nathan Bossart <[email-masked]>
Date: Wed, 15 Oct 2025 12:54:21 -0500

I just pushed 0001, and longfin and sifaka have very quickly reminded me
that we don't require C11 on v18.  Will fix shortly...

-- 
nathan

---

From: Nathan Bossart <[email-masked]>
Date: Wed, 15 Oct 2025 16:38:05 -0500

I've committed everything except for 0003, which I probably won't get to
until Friday.  Note that I decided against back-patching 0002 because of
the presumed rarity of and lack of reports for the bug.

-- 
nathan

---

From: Nathan Bossart <[email-masked]>
Date: Fri, 17 Oct 2025 11:56:04 -0500

> the presumed rarity of and lack of reports for the bug.

Everything tracked in this thread is now committed.

-- 
nathan