Subject: Re: failure to drop table due to pg_temp_7 schema

From: Adrian Klaver <[email-masked]>
Date: Sat, 15 Nov 2025 08:06:22 -0800

On 11/15/25 06:57, Peter 'PMc' Much wrote:
> Hi,

> Que is this: https://github.com/que-rb/que

Personally I would be more worried about an application
where the last commit was:

Changelog: Add entry for version 2.4.1
committed
on Oct 27, 2024.

Makes you wonder what will happen if you upgrade to a newer version
of Postgres?

> cheers,
> PMc

-- 
Adrian Klaver
[email-masked]

---

From: "Peter 'PMc' Much" <[email-masked]>
Date: Sat, 15 Nov 2025 19:10:53 +0100

On Sat, Nov 15, 2025 at 08:06:22AM -0800, Adrian Klaver wrote:
! On 11/15/25 06:57, Peter 'PMc' Much wrote:
! > 
! > Hi,
! 
! > Que is this: https://github.com/que-rb/que
! 
! Personally I would be more worried about an application
! where the last commit was:
! 
! Changelog: Add entry for version 2.4.1
! committed
! on Oct 27, 2024.

Really? I'd call that quite recently.

And there is an explanation: Rails has dropped automated support
for Que. That doesn't matter to me, because I'm not using it in the
automated fashion. But it means the big user base is gone, and
therewith the influx of improvement desires.

! Makes you wonder what will happen if you upgrade to a newer version
! of Postgres?

I'll see when I'm there. Still have to wait for the new kerberos in
FreeBSD - there will be a lot more to mangle anyway.

But speaking generally, I am quite bewildered that a simple tool
being stable for a year might already be considered worrisome.
Normally, a new technology brings a vast amount of innovation for
the first or second decade, and then it starts to stabilize. 
We in the IT do the opposite, we ever increase the change rate,
and I am wondering where this is supposed to lead.

cheers,
PMc