Subject: Re: strict-aliasing warning

From: Adrian Klaver <[email-masked]>
Date: Tue, 9 Dec 2025 19:04:23 -0800

On 12/9/25 18:27, ma lz wrote:

What version of Postgres?

> In function "ExecEvalJsonCoercionFinish()"
> 
>       if (SOFT_ERROR_OCCURRED(&jsestate->escontext))
> 
> may produce strict-aliasing warning

> Don't use IsA may fix this problem

Why is it a problem?

This is something that should be submitted here(you will need create a 
community account):

https://www.postgresql.org/account/login/?next=/account/submitbug/

-- 
Adrian Klaver
[email-masked]

---

From: Michael Paquier <[email-masked]>
Date: Wed, 10 Dec 2025 15:44:29 +0900

>> Don't use IsA may fix this problem

Well, I don't think that this has proved to be a problem until now in
the buildfarm.  I doubt that it would be the only problematic area if
a new compiler flag is enforced by a buildfarm member, assuming that
we would add one but the bar is very high when it comes to that.

A 4-line message is short to present your arguments, what you are
trying to do, and why it could make sense in some way.
--
Michael