Subject: Re: Bug: PG 14 recovery failure

From: David Rowley <[email-masked]>
Date: Wed, 18 Feb 2026 23:27:37 +1300

On Wed, 18 Feb 2026 at 21:40, Torsten Förtsch <[email-masked]> wrote:
> 2026-02-14 01:53:59.595 UTC [2441074] LOG: restored log file "0000000500017F8D0000004E" from archive 2026-02-14 01:53:59.605 UTC [2441074] FATAL: could not access status of transaction 2030956544

There's a planned out-of-cycle release to fix this. See [1].

David

[1] https://www.postgresql.org/about/news/out-of-cycle-release-scheduled-for-february-26-2026-3241/

---

From: Michael Paquier <[email-masked]>
Date: Thu, 19 Feb 2026 13:11:43 +0900

> There's a planned out-of-cycle release to fix this. See [1].

In more details, here is the specific fix in the v14~18 range:
https://git.postgresql.org/gitweb/?p=postgresql.git;a=commit;h=817f74600d0d

And its related thread:
https://www.postgresql.org/message-id/[email-masked];lightning.p46.dedyn.io
--
Michael