Subject: Re: configure && --with

From: Matthias Apitz <[email-masked]>
Date: Wed, 8 Apr 2026 21:10:17 +0200

El día miércoles, abril 08, 2026 a las 10:59:29a. m. -0400, Tom Lane escribió:

> Matthias Apitz <[email-masked]> writes:
> > but it still says in config.log
> 
> > ...
> > configure:14192: checking for openssl
> > configure:14210: found /usr/local/sisis-pap/bin/openssl
> > configure:14222: result: /usr/local/sisis-pap/bin/openssl
> > configure:14242: using openssl: openssl not found
> 
> You don't actually need to worry about that.  It's only trying to
> report the result of "openssl version" for documentation's sake.
> We don't use that executable for anything beyond that.

Ok, fine with me. But the implementation of '--with-libraries' is wrong
or at least the documentation needs clarification if this implementation
is intentionally.

	matthias

-- 
Matthias Apitz, ✉ [email-masked], http://www.unixarea.de/ +49-176-38902045
Public GnuPG key: http://www.unixarea.de/key.pub

In Cuba bei der Ankunft eines Schiffes mit Rohöl: "Endlich, die Russen sind da!
En Cuba al llegar un barco con crudo: "Por fin, los rusos llegan!"
Wann kommen sie endlich zu uns? ¿Cúando llegan por fin para acá?

---

From: Tom Lane <[email-masked]>
Date: Wed, 08 Apr 2026 15:23:45 -0400

> or at least the documentation needs clarification if this implementation

[ shrug... ]  I do not think it's incumbent on us to work with
broken openssl installations.  If your openssl doesn't cope
with being run without any special LD_LIBRARY_PATH setting,
you need to rethink how you're building it.

			regards, tom lane

---

From: Matthias Apitz <[email-masked]>
Date: Thu, 9 Apr 2026 08:08:23 +0200

> you need to rethink how you're building it.

Wrong! It's not build unusual, just with a dedicated
--prefix=/usr/local/sisis-pap,
just the same way as PostgreSQL can be build with the same --prefix.
The idea of this is to keep in customer servers all OpenSource own
compiled and delivered software below the same top level dir and not
pollute servers in other areas.

The implementation of --with-libraries in PostgreSQL's 'configure is
what I'd call: a bug. You should rethink about this

	matthias