Subject: Re: Interaction between "client_connection_check_interval" and "log_lock_waits" parameters

From: Adrian Klaver <[email-masked]>
Date: Wed, 3 Dec 2025 08:21:19 -0800

On 12/3/25 00:24, Alfonso Escribano wrote:
> Hello,
> I have seen an interaction between "client_connection_check_interval" 
> and "log_lock_waits" parameters that it isn't documented (or I can't 
> find it anywhere).

What version of Postgres?

> Regards,
> Alfonso Escribano

-- 
Adrian Klaver
[email-masked]

---

From: Alfonso Escribano <[email-masked]>
Date: Wed, 3 Dec 2025 17:38:28 +0100

Hello,

I have test it with postgresql 17.7

I have been searching on postgresql src for commits related with
client_connection_check_interval, and I only see initial commits in
postgresql 14, I think it happends in all versions from 14 until 18,
but I can only confirm on 17.7

Regards,

Alfonso Escribano

Adrian Klaver wrote:

On
12/3/25 00:24, Alfonso Escribano wrote:

Hello,

I have seen an interaction between
"client_connection_check_interval" and "log_lock_waits"
parameters that it isn't documented (or I can't find it
anywhere).

Regards,

Alfonso Escribano

--

Alfonso Escribano

[email-masked]

c/ Costa Brava 10 - 28034 Madrid

Office: +34 91
456 10 01

This email and any files transmitted with
it are confidential and may be privileged and are
intended solely for the use of the individual or
entity to whom they are addressed. If you are not an
addressee, any unauthorized direct or indirect
dissemination, distribution, publication, reading, or
copying of this message and any attachments is
strictly prohibited. If you have received this email
in error please notify the sender immediately, and
delete this email from your system. Email
communication does not guarantee the confidentiality,
integrity, or proper receipt of the messages sent.
Meteológica, S.A. accepts no liability for such
circumstances.