agora inbox for pgsql-general@postgresql.org  
help / color / mirror / Atom feed
Error Creating pgcrypto Extension
9+ messages / 8 participants
[nested] [flat]

* Error Creating pgcrypto Extension
@ 2026-09-17 20:24 Mark Hill <Mark.Hill@sas.com>
  2026-09-17 21:11 ` Re: Error Creating pgcrypto Extension David G. Johnston <david.g.johnston@gmail.com>
  0 siblings, 1 reply; 9+ messages in thread

From: Mark Hill @ 2026-09-17 20:24 UTC (permalink / raw)
  To: pgsql-general <pgsql-general@lists.postgresql.org>; +Cc: Phil Rau <Phil.Rau@sas.com>; Michael King <Michael.King@sas.com>; Ashley Stephens <Ashley.Stephens@sas.com>

We are trying to run this code in Postgres 18.6:
CREATE EXTENSION IF NOT EXISTS pgcrypto WITH SCHEMA pg_catalog CASCADE;

and getting the error
postgres=# CREATE EXTENSION IF NOT EXISTS pgcrypto WITH SCHEMA pg_catalog CASCADE;
ERROR:  function "gen_random_uuid" already exists with same argument types
CONTEXT:  SQL statement "CREATE FUNCTION gen_random_uuid()
RETURNS uuid
AS '$libdir/pgcrypto', 'pg_random_uuid'
LANGUAGE C VOLATILE PARALLEL SAFE"
extension script file "pgcrypto--1.3.sql", near line 66

That's because pgcrypto-1.3.sql has the following 4 lines starting at line 66:
CREATE FUNCTION gen_random_uuid()
RETURNS uuid
AS 'MODULE_PATHNAME', 'pg_random_uuid'
LANGUAGE C VOLATILE PARALLEL SAFE;

which try to create the gen_random_uuid() function but since it already exists it throws an error.

1)  Should pgcrytpo-1.3.sql be trying to create gen_random_uuid() if/when it already exists?


The pgcrypto.control file contains:
# pgcrypto extension
comment = 'cryptographic functions'
default_version = '1.4'
module_pathname = '$libdir/pgcrypto'
relocatable = true
trusted = true

2) given what's in pgcrypto.control should there be a pgcrypto-1.4.sql file?


NOTE:  If I comment lines 66-69 in pgcrypto-1.3.sql the
CREATE EXTENSION IF NOT EXISTS pgcrypto WITH SCHEMA pg_catalog CASCADE;
code completes successfully.

I'm hesitant to alter pgcrypto-1.3.sql.   Thoughts?

Thanks, Mark

^ permalink  raw  reply  [nested|flat] 9+ messages in thread

* Re: Error Creating pgcrypto Extension
  2026-09-17 20:24 Error Creating pgcrypto Extension Mark Hill <Mark.Hill@sas.com>
@ 2026-09-17 21:11 ` David G. Johnston <david.g.johnston@gmail.com>
  2026-09-18 00:05   ` Re: Error Creating pgcrypto Extension Tom Lane <tgl@sss.pgh.pa.us>
  0 siblings, 1 reply; 9+ messages in thread

From: David G. Johnston @ 2026-09-17 21:11 UTC (permalink / raw)
  To: Mark Hill <Mark.Hill@sas.com>; +Cc: pgsql-general <pgsql-general@lists.postgresql.org>; Phil Rau <Phil.Rau@sas.com>; Michael King <Michael.King@sas.com>; Ashley Stephens <Ashley.Stephens@sas.com>

On Thu, Sep 17, 2026 at 3:25 PM Mark Hill <Mark.Hill@sas.com> wrote:

> We are trying to run this code in Postgres 18.6:
>
> *CREATE EXTENSION IF NOT EXISTS pgcrypto WITH SCHEMA pg_catalog CASCADE;*
>


> which try to create the gen_random_uuid() function but since it already
> exists it throws an error.
>
> *1)  Should pgcrytpo—1.3.sql be trying to create gen_random_uuid() if/when
> it already exists?*
>

It's not expecting to be installed in the pg_catalog schema since it is an
extension.  Extensions don't usually conditionally install their components.


> *2) given what’s in pgcrypto.control should there be a pgcrypto—1.4.sql
> file?*
>

The pattern of a base full install and then incremental update scripts is
supported.

David J.

^ permalink  raw  reply  [nested|flat] 9+ messages in thread

* Re: Error Creating pgcrypto Extension
  2026-09-17 20:24 Error Creating pgcrypto Extension Mark Hill <Mark.Hill@sas.com>
  2026-09-17 21:11 ` Re: Error Creating pgcrypto Extension David G. Johnston <david.g.johnston@gmail.com>
@ 2026-09-18 00:05   ` Tom Lane <tgl@sss.pgh.pa.us>
  2026-09-18 09:43     ` Re: Error Creating pgcrypto Extension Daniel Gustafsson <daniel@yesql.se>
  0 siblings, 1 reply; 9+ messages in thread

From: Tom Lane @ 2026-09-18 00:05 UTC (permalink / raw)
  To: David G. Johnston <david.g.johnston@gmail.com>; +Cc: Mark Hill <Mark.Hill@sas.com>; pgsql-general <pgsql-general@lists.postgresql.org>; Phil Rau <Phil.Rau@sas.com>; Michael King <Michael.King@sas.com>; Ashley Stephens <Ashley.Stephens@sas.com>

"David G. Johnston" <david.g.johnston@gmail.com> writes:
> On Thu, Sep 17, 2026 at 3:25 PM Mark Hill <Mark.Hill@sas.com> wrote:
>> We are trying to run this code in Postgres 18.6:
>> *1)  Should pgcrytpo—1.3.sql be trying to create gen_random_uuid() if/when
>> it already exists?*

> It's not expecting to be installed in the pg_catalog schema since it is an
> extension.  Extensions don't usually conditionally install their components.

Yeah.  As of now, installing pgcrypto into pg_catalog is unsupported.

>> *2) given what’s in pgcrypto.control should there be a pgcrypto—1.4.sql
>> file?*

> The pattern of a base full install and then incremental update scripts is
> supported.

Installing 1.3 and then updating to a hypothetical 1.4 wouldn't work
anyway in this scenario, because installing 1.3 would fail.

We could perhaps decide that pgcrypto doesn't need to provide
gen_random_uuid anymore; maybe that backwards-compatibility hack
has served its time.  But I'm not sure if removing the function
would break anybody.  If we did go that way, we'd need to provide
a 1.3-to-1.4 update script that drops the function, and also a
pgcrypto--1.4 install script that rolls up all the prior updates
so that it never tries to create gen_random_uuid in the first place.

On the whole, seeing that installing pgcrypto into pg_catalog has
not worked since v13 and there's been hardly any complaints about
that, I'm not sure that we should risk breaking working setups to
allow it.

			regards, tom lane






^ permalink  raw  reply  [nested|flat] 9+ messages in thread

* Re: Error Creating pgcrypto Extension
  2026-09-17 20:24 Error Creating pgcrypto Extension Mark Hill <Mark.Hill@sas.com>
  2026-09-17 21:11 ` Re: Error Creating pgcrypto Extension David G. Johnston <david.g.johnston@gmail.com>
  2026-09-18 00:05   ` Re: Error Creating pgcrypto Extension Tom Lane <tgl@sss.pgh.pa.us>
@ 2026-09-18 09:43     ` Daniel Gustafsson <daniel@yesql.se>
  2026-09-18 14:33       ` RE: Error Creating pgcrypto Extension Phil Rau <Phil.Rau@sas.com>
  0 siblings, 1 reply; 9+ messages in thread

From: Daniel Gustafsson @ 2026-09-18 09:43 UTC (permalink / raw)
  To: Tom Lane <tgl@sss.pgh.pa.us>; +Cc: David G. Johnston <david.g.johnston@gmail.com>; Mark Hill <Mark.Hill@sas.com>; pgsql-general <pgsql-general@lists.postgresql.org>; Phil Rau <Phil.Rau@sas.com>; Michael King <Michael.King@sas.com>; Ashley Stephens <Ashley.Stephens@sas.com>

> On 18 Sep 2026, at 02:05, Tom Lane <tgl@sss.pgh.pa.us> wrote:

> On the whole, seeing that installing pgcrypto into pg_catalog has
> not worked since v13 and there's been hardly any complaints about
> that, I'm not sure that we should risk breaking working setups to
> allow it.

I wouldn't be opposed to removing gen_random_uuid from pgcrypto, it's a hack
and documented as obsolete in all supported versions.  Supporting installing
pgcrypto in pg_catalog would not be a motivator though, trimming unnecessary
code from pgcrypto is however appealing

--
Daniel Gustafsson







^ permalink  raw  reply  [nested|flat] 9+ messages in thread

* RE: Error Creating pgcrypto Extension
  2026-09-17 20:24 Error Creating pgcrypto Extension Mark Hill <Mark.Hill@sas.com>
  2026-09-17 21:11 ` Re: Error Creating pgcrypto Extension David G. Johnston <david.g.johnston@gmail.com>
  2026-09-18 00:05   ` Re: Error Creating pgcrypto Extension Tom Lane <tgl@sss.pgh.pa.us>
  2026-09-18 09:43     ` Re: Error Creating pgcrypto Extension Daniel Gustafsson <daniel@yesql.se>
@ 2026-09-18 14:33       ` Phil Rau <Phil.Rau@sas.com>
  2026-09-18 14:41         ` Re: Error Creating pgcrypto Extension Adrian Klaver <adrian.klaver@aklaver.com>
  2026-09-18 14:43         ` Re: Error Creating pgcrypto Extension Karsten Hilbert <Karsten.Hilbert@gmx.net>
  0 siblings, 2 replies; 9+ messages in thread

From: Phil Rau @ 2026-09-18 14:33 UTC (permalink / raw)
  To: Daniel Gustafsson <daniel@yesql.se>; Tom Lane <tgl@sss.pgh.pa.us>; +Cc: David G. Johnston <david.g.johnston@gmail.com>; Mark Hill <Mark.Hill@sas.com>; pgsql-general <pgsql-general@lists.postgresql.org>; Michael King <Michael.King@sas.com>; Ashley Stephens <Ashley.Stephens@sas.com>

Good morning, everyone.

Thank you for the discussion so far.  I work with the original poster and I wanted to be sure that we're not trying to accomplish our goal in the wrong way. So, please allow me to describe what we are trying to do.

We are trying to make our product compliant with the Federal Information Processing Standard (FIPS).  So, in addition to converting from MD5 to SCRAM-SHA-256 password hashing and enabling TLS, we also needed to have the pgcrypto extension deployed to each database in our instance.  Our initial thought would be to create the extension at the instance level, and then have any databases created inside of that instance get the extension without any extra commands.  That's why we were tying this command:

CREATE EXTENSION IF NOT EXISTS pgcrypto WITH SCHEMA pg_catalog CASCADE;

However, Tom Lane indicated that this is not supported.  So, it seems that we are not using the right method.

The question now becomes:  Is there a way to set up an instance such that any new databases created underneath it automatically get a given extension (in this case pgcrypto)?  What is the best practice to do this?

For this discussion, we can assume that we are starting with a fresh instance, without any databases yet created inside of it.

Thank you!

--
Phil Rau

-----Original Message-----
From: Daniel Gustafsson <daniel@yesql.se> 
Sent: Friday, September 18, 2026 5:44 AM
To: Tom Lane <tgl@sss.pgh.pa.us>
Cc: David G. Johnston <david.g.johnston@gmail.com>; Mark Hill <Mark.Hill@sas.com>; pgsql-general <pgsql-general@lists.postgresql.org>; Phil Rau <Phil.Rau@sas.com>; Michael King <Michael.King@sas.com>; Ashley Stephens <Ashley.Stephens@sas.com>
Subject: Re: Error Creating pgcrypto Extension

> On 18 Sep 2026, at 02:05, Tom Lane <tgl@sss.pgh.pa.us> wrote:

> On the whole, seeing that installing pgcrypto into pg_catalog has not 
> worked since v13 and there's been hardly any complaints about that, 
> I'm not sure that we should risk breaking working setups to allow it.

I wouldn't be opposed to removing gen_random_uuid from pgcrypto, it's a hack and documented as obsolete in all supported versions.  Supporting installing pgcrypto in pg_catalog would not be a motivator though, trimming unnecessary code from pgcrypto is however appealing

--
Daniel Gustafsson






^ permalink  raw  reply  [nested|flat] 9+ messages in thread

* Re: Error Creating pgcrypto Extension
  2026-09-17 20:24 Error Creating pgcrypto Extension Mark Hill <Mark.Hill@sas.com>
  2026-09-17 21:11 ` Re: Error Creating pgcrypto Extension David G. Johnston <david.g.johnston@gmail.com>
  2026-09-18 00:05   ` Re: Error Creating pgcrypto Extension Tom Lane <tgl@sss.pgh.pa.us>
  2026-09-18 09:43     ` Re: Error Creating pgcrypto Extension Daniel Gustafsson <daniel@yesql.se>
  2026-09-18 14:33       ` RE: Error Creating pgcrypto Extension Phil Rau <Phil.Rau@sas.com>
@ 2026-09-18 14:41         ` Adrian Klaver <adrian.klaver@aklaver.com>
  2026-09-18 14:54           ` Re: Error Creating pgcrypto Extension Adrian Klaver <adrian.klaver@aklaver.com>
  1 sibling, 1 reply; 9+ messages in thread

From: Adrian Klaver @ 2026-09-18 14:41 UTC (permalink / raw)
  To: Phil Rau <Phil.Rau@sas.com>; Daniel Gustafsson <daniel@yesql.se>; Tom Lane <tgl@sss.pgh.pa.us>; +Cc: David G. Johnston <david.g.johnston@gmail.com>; Mark Hill <Mark.Hill@sas.com>; pgsql-general <pgsql-general@lists.postgresql.org>; Michael King <Michael.King@sas.com>; Ashley Stephens <Ashley.Stephens@sas.com>

On 9/18/26 7:33 AM, Phil Rau wrote:
> Good morning, everyone.
> 
> Thank you for the discussion so far.  I work with the original poster and I wanted to be sure that we're not trying to accomplish our goal in the wrong way. So, please allow me to describe what we are trying to do.
> 
> We are trying to make our product compliant with the Federal Information Processing Standard (FIPS).  So, in addition to converting from MD5 to SCRAM-SHA-256 password hashing and enabling TLS, we also needed to have the pgcrypto extension deployed to each database in our instance.  Our initial thought would be to create the extension at the instance level, and then have any databases created inside of that instance get the extension without any extra commands.  That's why we were tying this command:
> 
> CREATE EXTENSION IF NOT EXISTS pgcrypto WITH SCHEMA pg_catalog CASCADE;
> 
> However, Tom Lane indicated that this is not supported.  So, it seems that we are not using the right method.
> 
> The question now becomes:  Is there a way to set up an instance such that any new d

https://www.postgresql.org/docs/18/manage-ag-templatedbs.html

"CREATE DATABASE actually works by copying an existing database. By 
default, it copies the standard system database named template1. Thus 
that database is the “template” from which new databases are made. If 
you add objects to template1, these objects will be copied into 
subsequently created user databases. ... "

atabases created underneath it automatically get a given extension (in 
this case pgcrypto)?  What is the best practice to do this?
> 
> For this discussion, we can assume that we are starting with a fresh instance, without any databases yet created inside of it.
> 
> Thank you!
> 
> --
> Phil Rau
> 
> -----Original Message-----
> From: Daniel Gustafsson <daniel@yesql.se>
> Sent: Friday, September 18, 2026 5:44 AM
> To: Tom Lane <tgl@sss.pgh.pa.us>
> Cc: David G. Johnston <david.g.johnston@gmail.com>; Mark Hill <Mark.Hill@sas.com>; pgsql-general <pgsql-general@lists.postgresql.org>; Phil Rau <Phil.Rau@sas.com>; Michael King <Michael.King@sas.com>; Ashley Stephens <Ashley.Stephens@sas.com>
> Subject: Re: Error Creating pgcrypto Extension
> 
>> On 18 Sep 2026, at 02:05, Tom Lane <tgl@sss.pgh.pa.us> wrote:
> 
>> On the whole, seeing that installing pgcrypto into pg_catalog has not
>> worked since v13 and there's been hardly any complaints about that,
>> I'm not sure that we should risk breaking working setups to allow it.
> 
> I wouldn't be opposed to removing gen_random_uuid from pgcrypto, it's a hack and documented as obsolete in all supported versions.  Supporting installing pgcrypto in pg_catalog would not be a motivator though, trimming unnecessary code from pgcrypto is however appealing
> 
> --
> Daniel Gustafsson
> 
> 
> 


-- 
Adrian Klaver
adrian.klaver@aklaver.com





^ permalink  raw  reply  [nested|flat] 9+ messages in thread

* Re: Error Creating pgcrypto Extension
  2026-09-17 20:24 Error Creating pgcrypto Extension Mark Hill <Mark.Hill@sas.com>
  2026-09-17 21:11 ` Re: Error Creating pgcrypto Extension David G. Johnston <david.g.johnston@gmail.com>
  2026-09-18 00:05   ` Re: Error Creating pgcrypto Extension Tom Lane <tgl@sss.pgh.pa.us>
  2026-09-18 09:43     ` Re: Error Creating pgcrypto Extension Daniel Gustafsson <daniel@yesql.se>
  2026-09-18 14:33       ` RE: Error Creating pgcrypto Extension Phil Rau <Phil.Rau@sas.com>
  2026-09-18 14:41         ` Re: Error Creating pgcrypto Extension Adrian Klaver <adrian.klaver@aklaver.com>
@ 2026-09-18 14:54           ` Adrian Klaver <adrian.klaver@aklaver.com>
  0 siblings, 0 replies; 9+ messages in thread

From: Adrian Klaver @ 2026-09-18 14:54 UTC (permalink / raw)
  To: Phil Rau <Phil.Rau@sas.com>; Daniel Gustafsson <daniel@yesql.se>; Tom Lane <tgl@sss.pgh.pa.us>; +Cc: David G. Johnston <david.g.johnston@gmail.com>; Mark Hill <Mark.Hill@sas.com>; pgsql-general <pgsql-general@lists.postgresql.org>; Michael King <Michael.King@sas.com>; Ashley Stephens <Ashley.Stephens@sas.com>

On 9/18/26 7:41 AM, Adrian Klaver wrote:
> On 9/18/26 7:33 AM, Phil Rau wrote:
>> Good morning, everyone.
>>
>> Thank you for the discussion so far.  I work with the original poster 
>> and I wanted to be sure that we're not trying to accomplish our goal 
>> in the wrong way. So, please allow me to describe what we are trying 
>> to do.
>>
>> We are trying to make our product compliant with the Federal 
>> Information Processing Standard (FIPS).  So, in addition to converting 
>> from MD5 to SCRAM-SHA-256 password hashing and enabling TLS, we also 
>> needed to have the pgcrypto extension deployed to each database in our 
>> instance.  Our initial thought would be to create the extension at the 
>> instance level, and then have any databases created inside of that 
>> instance get the extension without any extra commands.  That's why we 
>> were tying this command:
>>
>> CREATE EXTENSION IF NOT EXISTS pgcrypto WITH SCHEMA pg_catalog CASCADE;
>>
>> However, Tom Lane indicated that this is not supported.  So, it seems 
>> that we are not using the right method.
>>
>> The question now becomes:  Is there a way to set up an instance such 
>> that any new d
> 
> https://www.postgresql.org/docs/18/manage-ag-templatedbs.html
> 
> "CREATE DATABASE actually works by copying an existing database. By 
> default, it copies the standard system database named template1. Thus 
> that database is the “template” from which new databases are made. If 
> you add objects to template1, these objects will be copied into 
> subsequently created user databases. ... "

In previous post I should have added a caveat, that from here:

https://www.postgresql.org/docs/18/sql-createdatabase.html

"template

     The name of the template from which to create the new database, or 
DEFAULT to use the default template (template1).
"

So it is possible for someone to create a database using a template 
database other then template1.

> 
> atabases created underneath it automatically get a given extension (in 
> this case pgcrypto)?  What is the best practice to do this?
>>
>> For this discussion, we can assume that we are starting with a fresh 
>> instance, without any databases yet created inside of it.
>>
>> Thank you!
>>
>> -- 
>> Phil Rau
>>
Adrian Klaver
adrian.klaver@aklaver.com





^ permalink  raw  reply  [nested|flat] 9+ messages in thread

* Re: Error Creating pgcrypto Extension
  2026-09-17 20:24 Error Creating pgcrypto Extension Mark Hill <Mark.Hill@sas.com>
  2026-09-17 21:11 ` Re: Error Creating pgcrypto Extension David G. Johnston <david.g.johnston@gmail.com>
  2026-09-18 00:05   ` Re: Error Creating pgcrypto Extension Tom Lane <tgl@sss.pgh.pa.us>
  2026-09-18 09:43     ` Re: Error Creating pgcrypto Extension Daniel Gustafsson <daniel@yesql.se>
  2026-09-18 14:33       ` RE: Error Creating pgcrypto Extension Phil Rau <Phil.Rau@sas.com>
@ 2026-09-18 14:43         ` Karsten Hilbert <Karsten.Hilbert@gmx.net>
  2026-09-18 14:57           ` Re: Error Creating pgcrypto Extension Tim Gerber <tggerber@gmail.com>
  1 sibling, 1 reply; 9+ messages in thread

From: Karsten Hilbert @ 2026-09-18 14:43 UTC (permalink / raw)
  To: pgsql-general@lists.postgresql.org

Am Fri, Sep 18, 2026 at 02:33:33PM +0000 schrieb Phil Rau:

> The question now becomes:  Is there a way to set up an instance such that any new databases created underneath it automatically get a given extension (in this case pgcrypto)?  What is the best practice to do this?

Isn't the canonical way for that to install it into a
template database from which new databases get created
eventually ?

Karsten
-- 
GPG  40BE 5B0E C98E 1713 AFA6  5BC0 3BEA AC80 7D4F C89B





^ permalink  raw  reply  [nested|flat] 9+ messages in thread

* Re: Error Creating pgcrypto Extension
  2026-09-17 20:24 Error Creating pgcrypto Extension Mark Hill <Mark.Hill@sas.com>
  2026-09-17 21:11 ` Re: Error Creating pgcrypto Extension David G. Johnston <david.g.johnston@gmail.com>
  2026-09-18 00:05   ` Re: Error Creating pgcrypto Extension Tom Lane <tgl@sss.pgh.pa.us>
  2026-09-18 09:43     ` Re: Error Creating pgcrypto Extension Daniel Gustafsson <daniel@yesql.se>
  2026-09-18 14:33       ` RE: Error Creating pgcrypto Extension Phil Rau <Phil.Rau@sas.com>
  2026-09-18 14:43         ` Re: Error Creating pgcrypto Extension Karsten Hilbert <Karsten.Hilbert@gmx.net>
@ 2026-09-18 14:57           ` Tim Gerber <tggerber@gmail.com>
  0 siblings, 0 replies; 9+ messages in thread

From: Tim Gerber @ 2026-09-18 14:57 UTC (permalink / raw)
  To: pgsql-general@lists.postgresql.org

There's a few ways to accomplish this.

As others have mentioned, pg_catalog isn't the best way to go about this.
 From a schema perspective, you can install it in public or even better,
create a dedicated schema for all extensions (i.e. create schema
extensions;) and then place all of your extensions in there.  My preference
is to go with the dedicated extensions schema and then make sure the
extensions schema is part of the search_path.

To have pgcrypto (and any author extensions) get installed automatically
when you run a create database, you can create the extensions schema in the
template 1 database and install the needed extensions there.
Alternatively, if you don't want to mess with the template 1 database, you
can create a new template database and then set that to be the default by
issuing an ALTER DATABASE ... IS_TEMPLATE TRUE;   (see
https://www.postgresql.org/docs/current/sql-alterdatabase.html).

Personally, if I was doing this, I'd automate this with ansible (or your
favorite automation tool) and have the automation code create the database,
create the extensions schema,  create the extensions in the new schema, and
finally set the search_path,.

Best Regards,
Tim

On Fri, Sep 18, 2026 at 9:44 AM Karsten Hilbert <Karsten.Hilbert@gmx.net>
wrote:

> Am Fri, Sep 18, 2026 at 02:33:33PM +0000 schrieb Phil Rau:
>
> > The question now becomes:  Is there a way to set up an instance such
> that any new databases created underneath it automatically get a given
> extension (in this case pgcrypto)?  What is the best practice to do this?
>
> Isn't the canonical way for that to install it into a
> template database from which new databases get created
> eventually ?
>
> Karsten
> --
> GPG  40BE 5B0E C98E 1713 AFA6  5BC0 3BEA AC80 7D4F C89B
>
>
>

^ permalink  raw  reply  [nested|flat] 9+ messages in thread


end of thread, other threads:[~2026-09-18 14:57 UTC | newest]

Thread overview: 9+ messages (download: mbox mbox.gz follow: Atom feed)
-- links below jump to the message on this page --
2026-09-17 20:24 Error Creating pgcrypto Extension Mark Hill <Mark.Hill@sas.com>
2026-09-17 21:11 ` David G. Johnston <david.g.johnston@gmail.com>
2026-09-18 00:05   ` Tom Lane <tgl@sss.pgh.pa.us>
2026-09-18 09:43     ` Daniel Gustafsson <daniel@yesql.se>
2026-09-18 14:33       ` Phil Rau <Phil.Rau@sas.com>
2026-09-18 14:41         ` Adrian Klaver <adrian.klaver@aklaver.com>
2026-09-18 14:54           ` Adrian Klaver <adrian.klaver@aklaver.com>
2026-09-18 14:43         ` Karsten Hilbert <Karsten.Hilbert@gmx.net>
2026-09-18 14:57           ` Tim Gerber <tggerber@gmail.com>

This inbox is served by agora; see mirroring instructions
for how to clone and mirror all data and code used for this inbox