Subject: Re: Restore of a reference database kills the auto analyze processing.

From: HORDER Philip <[email-masked]>
Date: Thu, 16 May 2024 10:08:12 +0000

Classified as: {OPEN}

> --oids have not been supported with pg_dump since v11

You're absolutely correct, this command came from my notes, which are obviously out of date.

We're running Postgres 15 pg_dump, and I've updated my notes.
I'm double-checking the command options with the guy who creates these files, but he's on holiday.  I expect we just dropped the OID option.

> FYI, --blobs is only needed when dumping a specific table or schema, otherwise it happens by default.

Thanks, I didn’t know that.

Phil Horder
Database Mechanic

Thales
Land & Air Systems

{OPEN}
The information contained in this e-mail is confidential. It is intended only for the stated addressee(s) and access to it by any other person is unauthorised. If you are not an addressee, you must not disclose, copy, circulate or in any other way use or rely on the information contained in this e-mail. Such unauthorised use may be unlawful. If you have received this e-mail in error, please inform the originator immediately and delete it and all copies from your system.

Thales UK Limited. A company registered in England and Wales. Registered Office: 350 Longwater Avenue, Green Park, Reading, Berks RG2 6GF. Registered Number: 868273

Please consider the environment before printing a hard copy of this e-mail.

---

From: Adrian Klaver <[email-masked]>
Date: Thu, 16 May 2024 07:28:33 -0700

> Thanks, I didn’t know that.

Did you have chance to do below?

 > From yesterday, current stats for table a.accp, from pg_STAT_all_tables:
 >"811486381""airscape""accp"16458538988177871456553503047055581967135016364880294000"2024-05-14 14:51:37.158892+00""2024-05-09 08:27:45.328468+00""2024-05-14 13:15:31.999198+00"01815170101653

I can't parse this out well enough to really say anything. Though the 
timestamps seem to indicate recent activity.

Using psql do

\x
select * from pg_stat_all_tables where relname = 'a.accp';

to get an extended output that is easier to read.

-- 
Adrian Klaver
[email-masked]