Subject: Re: Restore of a reference database kills the auto analyze processing.

From: HORDER Philip <[email-masked]>
Date: Thu, 23 May 2024 13:01:16 +0000

Classified as: {OPEN}

I actually hadn't thought to look for Postgres bugs, the system is so reliable for us, it just doesn't go wrong!

I can trigger the fault be running a reload of the lfm database, and we've been running Postgres 10 & 13 for several years now without seeing this problem.

Our symptoms match that bug description exactly, so I'm pretty confident this is the problem.
I'll have to push through the right paperwork to get a Postgres update, and that will take a while

Thank you so much for your time.

Phil Horder
Database Mechanic

Thales
Land & Air Systems

{OPEN}
The information contained in this e-mail is confidential. It is intended only for the stated addressee(s) and access to it by any other person is unauthorised. If you are not an addressee, you must not disclose, copy, circulate or in any other way use or rely on the information contained in this e-mail. Such unauthorised use may be unlawful. If you have received this e-mail in error, please inform the originator immediately and delete it and all copies from your system.

Thales UK Limited. A company registered in England and Wales. Registered Office: 350 Longwater Avenue, Green Park, Reading, Berks RG2 6GF. Registered Number: 868273

Please consider the environment before printing a hard copy of this e-mail.

---

From: Adrian Klaver <[email-masked]>
Date: Thu, 23 May 2024 07:45:08 -0700

> I'll have to push through the right paperwork to get a Postgres update, and that will take a while

While you are doing the paperwork make sure it is for upgrade to 15.7. 
Also might mention minor upgrades (x in X.x) are a good idea as 
Postgres, like any software, does get bugs and the minor releases fix 
them. Point the folks in charge at:

https://www.postgresql.org/docs/15/release.html

Also minor releases as a rule do not require dump/restore or pg_upgrade 
or other heavy lifting. There have been exceptions, but they are rare.

-- 
Adrian Klaver
[email-masked]