Subject: Re: Convert date and time colums to datetime

From: Rob Sargent <[email-masked]>
Date: Sun, 19 Oct 2025 13:40:59 -0600

> On Oct 19, 2025, at 1:08 PM, Rich Shepard <[email-masked]> wrote:
> 
> On Sun, 19 Oct 2025, Laurenz Albe wrote:
> 
>> That depends on what you do with the table.
> 
> Laurenz,
> 
> That makes sense.
> 
>> Are your SQL statements simple and natural with the current design?
>> Then stick with what you have now.
> 
> That's what I'm going to do. I was curious when a timestamp column was more
> efficient, or otherwise preferred, since only a couple of my databases have
> a table with both date and time. And neither has many rows, but one could be
> quite large some time in the future.
> 
> Thanks very much,
> 
> Rich
> 
I think you have to ask why those values were separated in the first place. For instance if they are thought of as a pair in most queries then an alteration might be in order. There can be a large one time cost if these tables occur in a lot of separate sql calls in the business logic.

---

From: Rich Shepard <[email-masked]>
Date: Sun, 19 Oct 2025 13:38:11 -0700 (PDT)

On Sun, 19 Oct 2025, Rob Sargent wrote:

> I think you have to ask why those values were separated in the first
> place. For instance if they are thought of as a pair in most queries then
> an alteration might be in order. There can be a large one time cost if
> these tables occur in a lot of separate sql calls in the business logic.

Rob,

Good point. They're in the contacts table and I use them to determine when
to make another contact and if prior contacts were more productive in the
morning or afternoon.

Thanks,

Rich