Subject: Re: Dump version issues

From: Pawel Veselov <[email-masked]>
Date: Wed, 23 Apr 2025 22:02:25 +0200

On Wed, Apr 23, 2025 at 9:13 PM Adrian Klaver <[email-masked]> wrote:

> On 4/23/25 11:46, Pawel Veselov wrote:
> > Hello.
>
> > So, how come older software (according to versions) produces dump
> > files with a greater version
> > than the newer software can understand? Is this Ubuntu package
> > maintainers messing things up?
>
> Do:
>
> man postgresql-common
>
> to see how this handled.
>
> I have found that it is best to be explicit using the --cluster option.

Thank you, I would have never guessed.

$ pg_dump -V -h x
pg_dump (PostgreSQL) 17.4 (Ubuntu 17.4-1.pgdg22.04+2)
$ pg_dump -V
pg_dump (PostgreSQL) 12.20 (Ubuntu 12.20-0ubuntu0.20.04.1)

(facepalm)

I was using the latter checking what pg_dump version was actually being used.
Wasn't aware of this pg_wrapper business.

> Given a pg_dump, it would be nice if its "-V" output would say which
> version of the dump it would produce

Yeah, this wouldn't have helped a bit.

---

From: Adrian Klaver <[email-masked]>
Date: Wed, 23 Apr 2025 13:19:02 -0700

> Wasn't aware of this pg_wrapper business.

If you do something like:

ls -al /usr/bin/pg_dump

you will find pg_dump is a sym link to:

/usr/share/postgresql-common/pg_wrapper

which is a Perl script that does the selection.

The same holds for the other Postgres commands in /usr/bin/.

FYI, psql will always resolve to latest version installed, --cluster 
will have no affect on it.

-- 
Adrian Klaver
[email-masked]