Subject: Re: Libpq.dll

From: Adrian Klaver <[email-masked]>
Date: Wed, 6 Aug 2025 10:46:39 -0700

On 8/6/25 06:17, [email-masked] wrote:
> Hello, how are you? I'm asking for help. When I try to compile a 32-bit 
> executable, in my 32-bit Delphi as well, in my 64-bit operating system, 
> an error appears about libpq.dll, saying that it was found, but not 
> loaded. Can you help me with this?

1) Please do not use whatever HTML markup/image you wrote the previous 
post in.

2) This needs more information:

a) OS and version of same.

b) The configuration and compilation steps you took.

c) The complete error message.

-- 
Adrian Klaver
[email-masked]

---

From: Adrian Klaver <[email-masked]>
Date: Wed, 6 Aug 2025 13:02:11 -0700

On 8/6/25 11:24, [email-masked] wrote:
>
> 
> The executable's libpq is 32-bit, and its dependencies are correct and 
> on the same architecture. In my Postgres, libpq was on a 64-bit 

You need to give more details on what '... my Postgres ...' is?

Did you download it as package or did you build it?

In either case what was the source?

> architecture, so I downloaded the 32-bit libdll, and the error still 
> persisted.
> 
> c)"Error Message: Client-Library
> libpq.dll found but could not be loaded. Check compile-target and 
> library compatibility!"

Looks like you are mixing 32/64 bit libraries.