Subject: Re: PostgreSQL 18 not available for Noble?

From: Ray O'Donnell <[email-masked]>
Date: Sun, 28 Sep 2025 21:04:45 +0000

On 28 September 2025 21:54:01 Adrian Klaver <[email-masked]> wrote:

> On 9/28/25 13:46, Ray O'Donnell wrote:
>> Hi all,
>>
>> As per $subject - is PG 18 not available for Ubuntu Noble (24.04)?
>
> According to the below it is:
>
> https://www.postgresql.org/download/linux/ubuntu/

Hi Adrian,

That's what I though, right enough.

> Did you do?:
> sudo apt update

Pretty sure I did.... the laptop is put away now and my marriage will be in 
danger if I take it out again (joking!!), so I'll try again in the morning 
and report back.

Thanks for the response,

Ray.

---

From: Adrian Klaver <[email-masked]>
Date: Sun, 28 Sep 2025 14:17:30 -0700

> That's what I though, right enough.

I see it here:

https://apt.postgresql.org/pub/repos/apt/dists/noble-pgdg/

Check:

Are the PGDG repos set up in Tuxedo OS?

Or are is Tuxedo using the default Ubuntu repo, which is pinned at 
Postgres 16:

https://packages.ubuntu.com/noble/database/postgresql

> 
>> Did you do?:
>>
>> sudo apt update
> 
> Pretty sure I did.... the laptop is put away now and my marriage will be 
> in danger if I take it out again (joking!!), so I'll try again in the 
> morning and report back.
> 
> Thanks for the response,
> 
> Ray.
> 
> 

-- 
Adrian Klaver
[email-masked]

---

From: Ray O'Donnell <[email-masked]>
Date: Mon, 29 Sep 2025 15:43:41 +0000

> https://packages.ubuntu.com/noble/database/postgresql

Problem solved - it turned out I was doing something stupid - I hadn't 
downloaded the repository key from apt.postgresql.org. Once I did that, 
PG 18 installed without a hitch. I put it down to brain fog (I'm 
currently isolating with Covid)...

Thanks again for the help!

Ray.

-- 
Ray O'Donnell // Galway // Ireland
[email-masked]