Subject: Re: Version compatibility

From: Adrian Klaver <[email-masked]>
Date: Sat, 1 Mar 2025 17:06:40 -0800

On 3/1/25 21:17, Igor Korot wrote:

>>
>> Do you have a $HOME/.odbc.ini?
>>
>> Also in odbc.ini, per man odbc.ini, I believe you have to have something
>> like:
>>
>> [ODBC Data Sources]
>> Postgresql = This is my Postgres DSN.
> 
> I added it and now my odbc.n look like this:
> 
> [code]
> igor@IgorsGentoo ~/dbhandler/Debug $ cat /etc/unixODBC/odbc.ini
> [ODBC Data Sources]
> PostgreSQL = This is my Postgres DSN.
> 
> [PostgreSQL]
> Driver=PostgreSQL
> Server=localhost
> PORT=5432
> DATABASE=draft
> OOPTION=3
> USER=postgres
> PASSWORD=wasqra
> igor@IgorsGentoo ~/dbhandler/Debug $

Did the connection work after making the change?

> 
> [/code]
> 
> And there is no .odbc.nii n the ~:
> 
> [code]
> igor@IgorsGentoo ~/dbhandler/Debug $ ls -la ~/.o*
> -rw-r--r-- 1 igor igor 0 Mar  1 23:10 /home/igor/.odbc.ini
> igor@IgorsGentoo ~/dbhandler/Debug $ cat /home/igor/.odbc.ini
> igor@IgorsGentoo ~/dbhandler/Debug $
> [/code]
> 
> Apparently the file is created when  run "isql -v PostgreSQL".
> I will look into that.
> 
> Thx.
> 
> 
> 
>>
>>   From man odbc.ini:
>>
>> "[ODBC Data Sources] section
>>
>>          The required section [ODBC Data Sources] lists each data source name
>> (DSN) as a key. The associated values serve as comments. Each  entry
>> must be matched by an ini file [section] describing the data source.
>> "
>>
>>> I'd like to develop backward compatible software which is compatible
>>> with the oldest possible combination..
>>
>> Not following.
>>   From my experiences with the ODBC driver it is backwards compatible, so
>> I would think using a more recent version would be the preferred solution.
>>
>>
>>
>> --
>> Adrian Klaver
>> [email-masked]
>>

-- 
Adrian Klaver
[email-masked]

---

From: Igor Korot <[email-masked]>
Date: Sat, 1 Mar 2025 23:17:08 -0600

Hi, Adrian,

On Sat, Mar 1, 2025 at 12:31 PM Adrian Klaver <[email-masked]> wrote:
>
> On 3/1/25 14:17, Igor Korot wrote:
>
> Reply to list also.
> Ccing list.
>
> Comments inline.
>
> > Hi, Adrian,
> > On Sat, Mar 1, 2025 at 11:23 AM Adrian Klaver <[email-masked]
> > <mailto:[email-masked]>> wrote:
> >
> >     On 3/1/25 13:15, Igor Korot wrote:
> >      > Hi, ALL,
> >      > I have PostgreSQL version 13 and ODBC driver version 11
> >      > on my Gentoo box.
> >      >
> >      > Are they compatible? Can I still connect to the server?
> >
> >     Have you tried to make a connection?
> >
> >
> > Tried.
> >
> > [code]
> > IgorsGentoo/home/igor/dbhandler_new/Debug #cat /etc/unixODBC/odbcinst.ini
> > Trace=yes
> > TraceFile=/tmp/sql.log
> > [PostgreSQL]
> > Description=PostgreSQL drver
> > Driver=/usr/lib64/psqlodbcw.so
> >
> > IgorsGentoo/home/igor/dbhandler_new/Debug #cat /etc/unixODBC/odbc.ini
> > [PostgreSQL]
> > Driver=PostgreSQL
> > Server=localhost
> > PORT=5432
> > DATABASE=draft
> > OOPTION=3
> > USER=postgres
> > PASSWORD=wasqra
> > IgorsGentoo/home/igor/dbhandler_new/Debug #
> >
> > igor@IgorsGentoo~/dbhandler/Debug $isql -v PostgreSQL
> > [IM002][unixODBC][Driver Manager]Data source name not found and no
> > default driver specified
> > [ISQL]ERROR: Could not SQLConnect
> > igor@IgorsGentoo~/dbhandler/Debug $
> >
> > [/code]
>
> From:
>
> https://www.mankier.com/1/isql
>
> "DSN
>
>      The Data Source Name (DSN) used to connect to the SQL database.
> unixODBC looks for the specified DSN in /etc/odbc.ini and
> $HOME/.odbc.ini, with the latter taking precedence.
> "
>

[code]

[PostgreSQL]
Driver=PostgreSQL
Server=localhost
PORT=5432
DATABASE=draft
OOPTION=3
USER=postgres
PASSWORD=wasqra

[/code]

[code]

Thx.

---

From: Adrian Klaver <[email-masked]>
Date: Tue, 4 Mar 2025 13:00:53 -0800

On 3/4/25 3:00 PM, Igor Korot wrote:
> Hi, Adrian,
> 
> On Sat, Mar 1, 2025 at 7:06 PM Adrian Klaver <[email-masked]> wrote:
>>
>> On 3/
>>
> Sorry somehow missed that reply,
> 
> No still getting the same error...

This thread:

https://forums.gentoo.org/viewtopic-p-8856135.html

tells you what the problem is, the software is too old.

> Thank you.

---

From: Igor Korot <[email-masked]>
Date: Tue, 4 Mar 2025 15:05:27 -0600

Hi, Adrian,

> tells you what the problem is, the software is too old.

Which one?
The driver or DM?

Also, does this mean the driver is incompatible with the server version on
the protocol used?

Thank you.

---

From: Igor Korot <[email-masked]>
Date: Tue, 4 Mar 2025 17:00:23 -0600

Hi, Adrian,

Thank you.

---

From: Adrian Klaver <[email-masked]>
Date: Tue, 4 Mar 2025 15:24:53 -0800

>     tells you what the problem is, the software is too old.

I don't know enough about Gentoo to say.

If it where me I would upgrade both unixODBC and the Postgres driver to 
the latest that is supported for the distro.

> 
> Also, does this mean the driver is incompatible with the server version 
> on the protocol used?
> 
> Thank you.
> 
> 
>      >
>      > Thank you.
>      >
>      >>
>      >>>
> 
>     -- 
>     Adrian Klaver
>     [email-masked] <mailto:[email-masked]>
>