Subject: Re: postgres module in msvc

From: Adrian Klaver <[email-masked]>
Date: Mon, 23 Jun 2025 12:41:30 -0700

On 6/23/25 12:32, C. wrote:
> Hi there and thx for reading and answering if you can
> 
> 
> A few years ago, I wrote a pg module in C on gcc/linux. This module 
> works fine, and I'm striving to port on windows postgres edb, I compiled 
> the corresponding .dll wirh both mingw54 and msvc 2022, but got postgres 
> crashes.
>
Crashes with what errors?

> I also tried the recipe from
> https://www.enterprisedb.com/blog/compiling-postgresql-extensions-visual-studio-windows. <https://www.enterprisedb.com/blog/compiling-postgresql-extensions-visual-studio-windows.>
> 
> but no way.
> 
> Do you have a better available example ?
> 
> Thx again for reading
> 

-- 
Adrian Klaver
[email-masked]

---

From: Adrian Klaver <[email-masked]>
Date: Mon, 23 Jun 2025 13:44:16 -0700

On 6/23/25 13:19, C. wrote:

Reply to list also.
Ccing list.

> I don't know. The postgres kernel crashes, not the client
>   app.

So does the Postgres log show anything?

> On Monday, June 23, 2025 at 09:41:33 PM GMT+2, Adrian Klaver 
> <[email-masked]> wrote:
> 
> 
> [email-masked] <mailto:[email-masked]>
> 
>