Subject: Re: Restore of a reference database kills the auto analyze processing.

From: HORDER Philip <[email-masked]>
Date: Tue, 21 May 2024 20:44:16 +0000

Classified as: {OPEN}

2024-05-15 03:31:31.290 GMT [4556]: [3-1]
db=lfm,user=superuser,app=[unknown],client=::1 LOG:  connection
authorized: user=superuser database=lfm application_name=pg_restore

> That would be the lfm database being restored.
> What does the log show after that as pertains to autovacuum?

Yep, pg_restore recreates the dropped lfm database.
And after that.... nothing.
The log just holds connection requests, and a checkpoint every hour.
That's it.
No "automatic vacuum", or "automatic analyze" anywhere.
And nothing any day since then, for a week.

Phil Horder
Database Mechanic

Thales
Land & Air Systems

{OPEN}
The information contained in this e-mail is confidential. It is intended only for the stated addressee(s) and access to it by any other person is unauthorised. If you are not an addressee, you must not disclose, copy, circulate or in any other way use or rely on the information contained in this e-mail. Such unauthorised use may be unlawful. If you have received this e-mail in error, please inform the originator immediately and delete it and all copies from your system.

Thales UK Limited. A company registered in England and Wales. Registered Office: 350 Longwater Avenue, Green Park, Reading, Berks RG2 6GF. Registered Number: 868273

Please consider the environment before printing a hard copy of this e-mail.

---

From: Adrian Klaver <[email-masked]>
Date: Tue, 21 May 2024 14:52:03 -0700

> And nothing any day since then, for a week.

Just for confirmation your settings are still?:

autovacuum_max_workers = 10
log_autovacuum_min_duration = 0

You said previously:

"The only way I can find of getting the analyzer back is to restart 
Postgres."

To be clear this means:

1) The lfm database is dropped/created.

2) There is a round of autovacuum immediately after the lfm is restored.

3) autovacuum then goes silent.

4) Before the next drop/create lfm you restart the Postgres server and 
autovacuum starts again.

What is in the logs when you do the restart?

Is there some process that runs shortly after the drop/create lfm cycle?

-- 
Adrian Klaver
[email-masked]