Subject: Re: pg_combinebackup failure

From: Adrian Klaver <[email-masked]>
Date: Tue, 24 Jun 2025 08:26:40 -0700

On 6/24/25 02:31, Kouber Saparev wrote:
> Hello,
> 
> We are trying to use pg_combinebackup but eventually it fails with:

What is the command you are using to take the incremental backups?

What version of Postgres are you taking the incremental backups from?

Given the naming below, is Barman involved in this?

If Barman is involved what version and what command is being used?

> 
> pg_combinebackup --debug --dry-run 
> --output=/barman-backup/barman-data/test_combine 20250616T140003/data 
> 20250617T090005/data
> 
> ...
> 
> pg_combinebackup: would copy 
> "20250616T140003/data/base/16420/2136674204" to 
> "/barman-backup/barman-data/test_combine/base/16420/2136674204"
> pg_combinebackup: would copy 
> "20250616T140003/data/base/16420/2542449085" to 
> "/barman-backup/barman-data/test_combine/base/16420/2542449085"
> pg_combinebackup: error: file 
> "20250617T090005/data/base/16420/INCREMENTAL.4085177931.76" has 
> truncation block length 9501840 in excess of segment size 131072
> 
> Any idea what's wrong?
> 
> --
> Kouber Saparev

-- 
Adrian Klaver
[email-masked]

---

From: Kouber Saparev <[email-masked]>
Date: Tue, 24 Jun 2025 18:38:59 +0300

Barman is involved indeed, its version is 3.14. The command: "barman backup
xxx --incremental latest".

PostgreSQL is version 17.3.

---

From: Adrian Klaver <[email-masked]>
Date: Tue, 24 Jun 2025 08:48:53 -0700

On 6/24/25 08:38, Kouber Saparev wrote:
> Barman is involved indeed, its version is 3.14. The command: "barman 
> backup xxx --incremental latest".

I don't use Barman and I am still figuring out incremental backups, so 
what I say should be taken lightly.

 From here:

https://docs.pgbarman.org/release/3.14.1/user_guide/backup.html#block-level-incremental-backup

"Alternatively, you can use last-full or latest-full to reference the 
most recent eligible full backup in the catalog."

Not sure that latest by itself will work.

> На вт, 24.06.2025 г. в 18:26 Adrian Klaver <[email-masked] 
> <mailto:[email-masked]>> написа:
> 
>     [email-masked] <mailto:[email-masked]>
>