Subject: Re: [EXTERNAL] RDS IO Read time

From: Eden Aharoni <[email-masked]>
Date: Mon, 31 Mar 2025 17:54:08 +0000

So you believe it's strictly an EBS issue?

Get Outlook for Android<https://aka.ms/AAb9ysg>
________________________________
From: Christophe Pettus <[email-masked]>
Sent: Monday, March 31, 2025 8:43:19 PM
To: Eden Aharoni <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: Re: [EXTERNAL] RDS IO Read time

[You don't often get email from [email-masked]. Learn why this is important at https://aka.ms/LearnAboutSenderIdentification ]

> On Mar 31, 2025, at 10:32, Eden Aharoni <[email-masked]> wrote:
>
> First, thanks for the reply :)
> So, I do know which part is taking a lot of IO time and it's to be honest any node that reads from the disk.. of course, we're running EXPLAIN on our queries (to be more specific we use auto_explain) but we can't seem to find what could cause an index scan that reads 34 MB to take more than a second (1.2 sec).. we do know that our dataset doesn't fit the memory and we were ok with that but with IO being so slow we just don't know what to do anymore. Any other suggestions other than contact AWS (which we did but it seems this path won't lead anywhere).

The performance of EBS is definitely a question for AWS.  I can say that, in our experience, EBS mounts for RDS almost never approach the stated maximum throughput, although io2 tends to be closer than gp2 or gp3.

---

From: Christophe Pettus <[email-masked]>
Date: Mon, 31 Mar 2025 11:23:45 -0700

> On Mar 31, 2025, at 10:54, Eden Aharoni <[email-masked]> wrote:
> 

Well, PostgreSQL certainly can read faster than 34MB/s off of disk.  With the data you've given, I can't really say if it's purely an EBS issue.

---

From: Adrian Klaver <[email-masked]>
Date: Mon, 31 Mar 2025 11:33:59 -0700

>> So you believe it's strictly an EBS issue?

You are asking about disk I/O, that is the purview of the OS and 
hardware. In your case both are created and managed by AWS, only they 
know what is going on behind the scenes.

-- 
Adrian Klaver
[email-masked]