Subject: Clarification on RLS policy

From: Vydehi Ganti <[email-masked]>
Date: Fri, 25 Apr 2025 12:38:47 +0530

Hi Team,

We are presently using Postgresql:PostgreSQL 15.12 on x86_64-pc-linux-gnu,
compiled by gcc (GCC) 8.5.0 20210514 (Red Hat 8.5.0-23), 64-bit
I have a scenario where
1.I need to enforce RLS policy on a table for Select by calling a Function
2.The function would return a character varying string which should be
appended to the select as a filter.
Ex: Select * from employee would be appended with where 1=1;
3.When we try to implement it says the below error.
ERROR: invalid input syntax for type boolean: "1=1" CONTEXT: PL/pgSQL
function function name(name,name) while casting return value to function's
return type
4.It works fine on Oracle. Can you please suggest how to fix this issue?

Rg
Vydehi.

---

From: Achilleas Mantzios - cloud <[email-masked]>
Date: Fri, 25 Apr 2025 09:35:30 +0100

On 4/25/25 08:08, Vydehi Ganti wrote:
> Hi Team,
>
> We are presently using Postgresql:PostgreSQL 15.12 on 
> x86_64-pc-linux-gnu, compiled by gcc (GCC) 8.5.0 20210514 (Red Hat 
> 8.5.0-23), 64-bit
> I have a scenario where
> function function name(name,name) while casting return value to 
> function's return type

Just show the output of

\d <your_table>

and particularly the Policies: section. Then also show the source of 
your function and anything else involved.