Subject: Query on Patch and Upgrade History in PostgreSQL

From: loganathan P <[email-masked]>
Date: Wed, 24 Sep 2025 13:47:27 +0530

Dear All,

How do I find the date and time of applied minor patches and upgrades in a
PostgreSQL database level?

Thanks.

Regards,
Loganathan P

---

From: Laurenz Albe <[email-masked]>
Date: Wed, 24 Sep 2025 12:37:02 +0200

On Wed, 2025-09-24 at 13:47 +0530, loganathan P wrote:
> How do I find the date and time of applied minor patches and upgrades in a PostgreSQL database level?

This information is not stored inside the database.
A minor upgrade just means replacing the files and restarting the server.

If you are using a package manager, perhaps you can find the information there.

Yours,
Laurenz Albe