Subject: Re: Unable to connect to any data source for foreign server

From: Muhammad Salahuddin Manzoor <[email-masked]>
Date: Wed, 29 May 2024 15:15:11 +0500

Greetings,

While configuring ORG_FWD.
I hope you are setting path like server name and absolute path to file on
your network share and network share has appropriate permissions.

'\\remote_server\path\to\file.xlsx' on network share

Create user mapping if required.

check your config through
ogr_fdw_info -s "\\\\remote_server\\path\\to\\file.xlsx" -l

To diagnose the issue you can check permissions, network accessability,
path format should include server name and absolute file path and any
compatability issues.

Regards,
Salahuddin.

On Wed, 29 May 2024, 14:42 Russell Mercer, <[email-masked]> wrote:

> Hi,
>
> I'm running into a problem connecting to a foreign server with my
> Postgres database.  I am using the OGR_FDW trying to connect to an Excel
> "XLSX".  I had this database on another server, and the foreign server
> was set up and working properly there.  I am trying to change the path
> to the file which it is referencing, and I am now receiving an error.
> In addition, I tried to just create a new foreign server to that same
> "XLSX" file and it also gave the error of "Failed to connect to data
> source".
>
> I used the OGR_FDW_INfo tool to make sure I had the foreign server
> reference structured correctly, but it matches what I had before, and
> didn't make a difference.
>
> I'm a bit lost as to where to look for possible solutions.  One idea I
> have is that perhaps it is a permissions issue with accessing other
> files on the server where Postgres is installed, with the "postgres" user.
>
> Some basic info:
>
> Server:  Windows Server 2022
> PostgreSQL 16.2 - Installed using Stack Builder
>
> Any information or ideas as to a solution, would be very much appreciated.
>
> Thanks,
> Russell
>
>
>
>

---

From: Russell Mercer <[email-masked]>
Date: Wed, 5 Jun 2024 01:55:29 -0700

Hi,

Getting back to this after a bit.  I am still having no luck.  I checked 
the settings for the postgres windows user between the new and old 
servers, and ensure they are matching.  The user has full control over 
the directory the file I want to connect to is located in.

Here are the results from running ogr_fdw_info:

CREATE SERVER myserver
   FOREIGN DATA WRAPPER ogr_fdw
   OPTIONS (
     datasource '\\coib-gis\City_GIS\Data\Assessor\Current\CityofIB.xlsx',
     format 'XLSX');

CREATE FOREIGN TABLE cityofib (
   fid bigint,
   pn bigint,
   ckdigit varchar,
   tra integer,
   contrctcd integer,
   frctint integer,
   marstat varchar,
   ownstat varchar,
   ownname varchar,
   mailaddr varchar,
   zip integer,
   mlchgdt integer,
   stsno varchar,
   stsstreet varchar,
   prpcd integer,
   prpdesc varchar,
   cvnet integer,
   cvland integer,
   imps integer,
   pprop integer,
   applyr varchar,
   xcd1 integer,
   xamt1 integer,
   xcd2 varchar,
   xamt2 integer,
   xcd3 varchar,
   xamt3 integer,
   doctype integer,
   docno integer,
   docdat integer,
   mapno varchar,
   origcutno integer,
   origcutdt integer,
   tracutno integer,
   tracutdt integer,
   redrftno integer,
   redrftdt integer,
   oldtra integer,
   oldpn bigint,
   acre double precision,
   units integer,
   zone integer,
   usecode integer,
   srcd varchar,
   sryr integer,
   taxstst varchar,
   assmtyr integer,
   transdt integer,
   yreffct integer,
   tlvgarea integer,
   bedrms integer,
   baths integer,
   gstalls integer,
   pool varchar,
   view varchar,
   usqft integer,
   asqft integer
) SERVER myserver
OPTIONS (layer 'CityofIB');

When I run the command given above to create the server, I receive the 
following error:

ERROR:  unable to connect to data source 
"\\coib-gis\City_GIS\Data\Assessor\Current\CityofIB.xlsx"

SQL state: HV00N

This same error occurs whether I try to connect to an XLSX or even just 
a CSV.  Any ideas would be greatly appreciated.

Thanks,

Russell

On 5/29/2024 3:15 AM, Muhammad Salahuddin Manzoor wrote:
> I hope you are setting path like server name and absolute path to file 
> on your network share and network share has appropriate permissions.
>
> To diagnose the issue you can check permissions, network 
> accessability, path format should include server name and absolute 
> file path and any compatability issues.
>
> Regards,
> Salahuddin.
>