Subject: Re: Building v17 Beta2 on Windows

From: Dominique Devienne <[email-masked]>
Date: Tue, 6 Aug 2024 10:53:32 +0200

On Mon, Aug 5, 2024 at 2:26 PM David Rowley <[email-masked]> wrote:
> Meson is now the only available method for Visual Studio builds."

Thanks David. My colleague figured it out, thanks to your pointers. Cheers, --DD

---

From: Dominique Devienne <[email-masked]>
Date: Fri, 9 Aug 2024 13:40:00 +0200

> Thanks David. My colleague figured it out, thanks to your pointers. Cheers, --DD

FYI, we ran into a surprising change, going from using Makefiles in beta2,
to using Meson in beta3, on Linux, for consistency with the Windows build.
The libraries are now in lib64 instead of lib. Yet another change to adapt to.
No big deal, just not 100% backward compatible, that's all. --DD

---

From: 黄铎彦 <[email-masked]>
Date: Sun, 27 Oct 2024 20:52:16 +0800

Did you generate sln and vcxproj files, and open the sln?

I used `meson setup --backend=vs build` in latest code，got `build\postgresql.sln`. But aftetr I clicked "build -> build solution", I got compile error, messages like file not found somehow. (01build_log.txt)