Subject: Use streaming read I/O when enabling data checksums online

From: "cca5507" <[email-masked]>
Date: Wed, 3 Jun 2026 19:10:52 +0800

Hi hackers,

Attach a simple patch for $subject. I think we prefer streaming IO instead of
ReadBufferExtended(). Do I miss something?

--
Regards,
ChangAo Chen

---

From: Daniel Gustafsson <[email-masked]>
Date: Wed, 3 Jun 2026 15:25:08 +0200

> On 3 Jun 2026, at 13:10, cca5507 <[email-masked]> wrote:

> ReadBufferExtended(). Do I miss something?

Thanks!  This code was written well before read streams existed, and recent
work was focused on correctness of operation, that's the main reason it's using
ReadBufferExtended still.  We probably want do something like this once the
tree opens up after the v19 feature freeze.

--
Daniel Gustafsson

---

From: "cca5507" <[email-masked]>
Date: Thu, 4 Jun 2026 10:43:47 +0800

> tree opens up after the v19 feature freeze.

Get it! I created a CF entry for this:

https://commitfest.postgresql.org/patch/6841/

--
Regards,
ChangAo Chen