public inbox for [email protected]  
help / color / mirror / Atom feed
From: Peter Eisentraut <[email protected]>
To: Dagfinn Ilmari MannsÃ¥ker <[email protected]>
Cc: pgsql-hackers <[email protected]>
Subject: Re: Remove useless casts to (char *)
Date: Sun, 23 Feb 2025 15:23:57 +0100
Message-ID: <[email protected]> (raw)
In-Reply-To: <[email protected]>
References: <[email protected]>
	<[email protected]>
	<[email protected]>
	<[email protected]>

I have committed the rest of this with the adjustments you suggested.


On 10.02.25 18:44, Dagfinn Ilmari Mannsåker wrote:
>>   Here is a new patch set rebased over that.
> 
> I had a more thorough read-through this time (as well as applying and
> building it), and it does make the code a lot more readable.
> 
> I noticed you in some places added extra parens around remaining casts
> with offset additions, e.g.
> 
> -		XLogRegisterData((char *) old_key_tuple->t_data + SizeofHeapTupleHeader,
> +		XLogRegisterData(((char *) old_key_tuple->t_data) + SizeofHeapTupleHeader,
>   						 old_key_tuple->t_len - SizeofHeapTupleHeader);
> 
> But not in others:
> 
> -		memcpy((char *) tuple->t_data + SizeofHeapTupleHeader,
> -			   (char *) data,
> -			   datalen);
> +		memcpy((char *) tuple->t_data + SizeofHeapTupleHeader, data, datalen);
> 
> 
> I don't have a particularly strong opinion either way (maybe -0.2 on the
> extra parens), but I mainly think we should keep it consistent, and not
> change it gratuitously.
> 
> Greppig indicates to me that the paren-less version is more common:
> 
> $ git grep -P '\(\w+\s*\**\) [\w>-]+ \+ \w+' | wc -l
> 283
> $ git grep -P '\(\(\w+\s*\**\) [\w>-]+\) \+ \w+' | wc -l
> 96
> 
> So I think we should leave them as they are.
> 
> - ilmari
> 
> 







view thread (5+ messages)  latest in thread

reply

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Reply to all the recipients using the --to and --cc options:
  reply via email

  To: [email protected]
  Cc: [email protected], [email protected]
  Subject: Re: Remove useless casts to (char *)
  In-Reply-To: <[email protected]>

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

This inbox is served by agora; see mirroring instructions
for how to clone and mirror all data and code used for this inbox