Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtps (TLS1.3:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.92) (envelope-from ) id 1oMA59-000303-Vh for pgsql-hackers@arkaria.postgresql.org; Thu, 11 Aug 2022 15:26:47 +0000 Received: from localhost ([127.0.0.1] helo=malur.postgresql.org) by malur.postgresql.org with esmtp (Exim 4.92) (envelope-from ) id 1oMA58-0008Ec-9S for pgsql-hackers@arkaria.postgresql.org; Thu, 11 Aug 2022 15:26:46 +0000 Received: from magus.postgresql.org ([2a02:c0:301:0:ffff::29]) by malur.postgresql.org with esmtps (TLS1.3:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.92) (envelope-from ) id 1oMA57-0008ER-Vv for pgsql-hackers@lists.postgresql.org; Thu, 11 Aug 2022 15:26:45 +0000 Received: from sss.pgh.pa.us ([66.207.139.130]) by magus.postgresql.org with esmtps (TLS1.3:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.92) (envelope-from ) id 1oMA55-0005W6-TQ for pgsql-hackers@postgresql.org; Thu, 11 Aug 2022 15:26:45 +0000 Received: from sss1.sss.pgh.pa.us (localhost [127.0.0.1]) by sss.pgh.pa.us (8.15.2/8.15.2) with ESMTP id 27BFQd3F011299; Thu, 11 Aug 2022 11:26:39 -0400 From: Tom Lane To: Andres Freund cc: Peter Eisentraut , Michael Paquier , Justin Pryzby , pgsql-hackers@postgresql.org Subject: Re: pg_upgrade test writes to source directory In-reply-to: <20220811152028.znxm5fpxjhe43hzw@awork3.anarazel.de> References: <2464542.1653603596@sss.pgh.pa.us> <2480063.1653609068@sss.pgh.pa.us> <20220528195949.tte5fukfr2z6xhrr@alap3.anarazel.de> <3131727.1653768841@sss.pgh.pa.us> <571133.1654095328@sss.pgh.pa.us> <20220811152028.znxm5fpxjhe43hzw@awork3.anarazel.de> Comments: In-reply-to Andres Freund message dated "Thu, 11 Aug 2022 08:20:28 -0700" MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-ID: <11297.1660231599.1@sss.pgh.pa.us> Date: Thu, 11 Aug 2022 11:26:39 -0400 Message-ID: <11298.1660231599@sss.pgh.pa.us> List-Id: List-Help: List-Subscribe: List-Post: List-Owner: List-Archive: Archived-At: Precedence: bulk Andres Freund writes: > On 2022-06-01 10:55:28 -0400, Tom Lane wrote: >> [...] I'm definitely not happy with the proposed changes to >> 010_tab_completion.pl. My recollection is that those tests >> were intentionally written to test tab completion involving a >> directory name, but this change just loses that aspect entirely. > How about creating a dedicated directory for the created files, to maintain > that? My goal of being able to redirect the test output elsewhere can be > achieved with just a hunk like this: Sure, there's no need for these files to be in the exact same place that the output is collected. I just want to keep their same relationship to the test's CWD. > Of course it'd need a comment adjustment etc. It's a bit ugly to use a > otherwise empty tmp_check/ directory just to reduce the diff size, but it's > also not too bad. Given that it's no longer going to be the same tmp_check dir used elsewhere, maybe we could s/tmp_check/tab_comp_dir/g or something like that? That'd add some clarity I think. regards, tom lane