Received: from makus.postgresql.org (makus.postgresql.org [98.129.198.125]) by mail.postgresql.org (Postfix) with ESMTP id 62DA379D55 for ; Thu, 12 Jul 2012 01:45:26 -0300 (ADT) Received: from mailout-de.gmx.net ([213.165.64.22]) by makus.postgresql.org with smtp (Exim 4.72) (envelope-from ) id 1SpBHI-0003tX-Eh for pgsql-hackers@postgresql.org; Thu, 12 Jul 2012 04:45:25 +0000 Received: (qmail invoked by alias); 12 Jul 2012 04:45:11 -0000 Received: from a88-115-214-103.elisa-laajakaista.fi (EHLO [10.0.0.103]) [88.115.214.103] by mail.gmx.net (mp034) with SMTP; 12 Jul 2012 06:45:11 +0200 X-Authenticated: #495269 X-Provags-ID: V01U2FsdGVkX1+6rTA+Yhe6pUJ6W2tGTSZJIn36QJmImRuAT/kb4g FtmhTsEX5Yhc6o Message-ID: <1342068308.15204.0.camel@vanquo.pezone.net> Subject: Re: pgsql_fdw in contrib From: Peter Eisentraut To: Kohei KaiGai Cc: Shigeru HANADA , PostgreSQL-development Date: Thu, 12 Jul 2012 07:45:08 +0300 In-Reply-To: References: <4FD9D947.1020803@gmail.com> <1342040659.2712.14.camel@vanquo.pezone.net> Content-Type: text/plain; charset="UTF-8" X-Mailer: Evolution 3.4.3-1 Mime-Version: 1.0 Content-Transfer-Encoding: 7bit X-Y-GMX-Trusted: 0 X-Pg-Spam-Score: -1.9 (-) X-Archive-Number: 201207/530 X-Sequence-Number: 211213 On tor, 2012-07-12 at 06:25 +0200, Kohei KaiGai wrote: > 2012/7/11 Peter Eisentraut : > > On tor, 2012-06-14 at 21:29 +0900, Shigeru HANADA wrote: > >> I'd like to propose pgsql_fdw, FDW for PostgreSQL, as a contrib module > >> in core, again. > > > > Do you have any new proposals regarding naming, and how to deal with > > postgresql_fdw_validator, and dblink? > > > This patch uses pgsql_fdw_validator for its own validator naming. > > Which point was the main issue in the last commit-fest? That this module should be called postgresql_fdw.