Received: from malur.postgresql.org ([217.196.149.56]) by arkaria.postgresql.org with esmtp (Exim 4.84_2) (envelope-from ) id 1aun3w-0002fq-MV for pgsql-hackers@arkaria.postgresql.org; Mon, 25 Apr 2016 20:24:56 +0000 Received: from localhost ([127.0.0.1] helo=postgresql.org) by malur.postgresql.org with smtp (Exim 4.84_2) (envelope-from ) id 1aun3w-0003mc-31 for pgsql-hackers@arkaria.postgresql.org; Mon, 25 Apr 2016 20:24:56 +0000 Received: from magus.postgresql.org ([2a02:c0:301:0:ffff::29]) by malur.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA384:256) (Exim 4.84_2) (envelope-from ) id 1aun3u-0003ls-TX for pgsql-hackers@postgresql.org; Mon, 25 Apr 2016 20:24:54 +0000 Received: from sss.pgh.pa.us ([66.207.139.130]) by magus.postgresql.org with esmtps (TLS1.2:ECDHE_RSA_AES_256_CBC_SHA384:256) (Exim 4.84_2) (envelope-from ) id 1aun3r-0002QP-Rs for pgsql-hackers@postgresql.org; Mon, 25 Apr 2016 20:24:54 +0000 Received: from sss1.sss.pgh.pa.us (localhost [127.0.0.1]) by sss.pgh.pa.us (8.14.4/8.14.4) with ESMTP id u3PKOhko014955; Mon, 25 Apr 2016 16:24:43 -0400 From: Tom Lane To: Robert Haas cc: Alvaro Herrera , Magnus Hagander , Bruce Momjian , PostgreSQL-development Subject: Re: Rename max_parallel_degree? In-reply-to: References: <2219.1461523373@sss.pgh.pa.us> <20160425185804.GA415608@alvherre.pgsql> Comments: In-reply-to Robert Haas message dated "Mon, 25 Apr 2016 16:10:35 -0400" Date: Mon, 25 Apr 2016 16:24:43 -0400 Message-ID: <14954.1461615883@sss.pgh.pa.us> X-Pg-Spam-Score: -2.9 (--) List-Archive: List-Help: List-ID: List-Owner: List-Post: List-Subscribe: List-Unsubscribe: X-Mailing-List: pgsql-hackers Precedence: bulk Sender: pgsql-hackers-owner@postgresql.org Robert Haas writes: >> What about calling it something even simpler, such as "max_parallelism"? >> This avoids such cargo cult, and there's no implication that it's >> per-query. > So what would we call the "parallel_degree" member of the Path data > structure, and the "parallel_degree" reloption? I don't think > renaming either of those to "parallelism" is going to be an > improvement. I think we should rename all of these to something based on the concept of "number of worker processes", and adjust the code if necessary to match. I think the "degree" terminology is fundamentally tainted by the question of whether or not it counts the leader, and that we will have bugs (or indeed may have them today) caused by getting that wrong. Your arguments for not changing it seem to me not to address that point; you've merely focused on the question of whether we have the replacement terminology right. If we don't, let's make it so, but the current situation is not good. regards, tom lane -- Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers